Shotcut does not see my Blue Yeti USB microphone

I installed a new Blue Yeti USB microphone. Defined that microphone as my input device in Setting. And successfully test that microphone with Logitech G Hub software and wireless JBL blue tooth speaker.
Start Shotcut with an old file and tried to set the microphone by Open Other → Video/Audio Device. The Video/Audio Device window shown no audio device as Audio input: None.
Please help.

I got help from Microsoft support. He finally uninstall Shotcut and reinstall it with installing file from Fosshub instead of Microsoft Store and Shotcut can see my microphone and video device now.
Reinstall with Microsoft Store software do not work.

Weird. These are the exact same builds, and the Store version (on Windows 10) sees and works with the Marantz USB microphone that I have. However it does not surprise me that jiggling around some software gets something working. You can have both installed if you want to try it again. You will just need to pay close attention to the difference in how to launch each.

Theoretically, you are right… But the Microsoft Support agent took a long time to try in front of me. He tried to uninstall then re-install Shotcut with Microsoft Store twice and fail every time. That is why he wanted to try to re-install with another installation source and it works.

I dont know what wrong with version of Microsoft Store but when I install it with Microsoft Store version, I discovered that version is not an up to date version but I did not do anything at that time as I was new to Shotcut and for what I did, it works fine thus I was not worry too much, until I want to record voices of a few other languages to add to a video. This is to create the same video with other language voice while muting the original voice.

This topic was automatically closed after 90 days. New replies are no longer allowed.