Shotcut does not open

I think it is the 2n time it happens in not many months, maybe because there have been so often program updates. So, Shotcut does not start in my computer, which has a Linux OS (Ubuntu 18.04.6 LTS). I have deinstalled the program and reinstalled, but it still does not open. I wanted to read related threads, but some popups have not let me do it.

From the release notes

The minimum version of our non-Flatpak Linux binaries is now based on Ubuntu 20.04 LTS, which uses glibc 2.31. This is due to modern C++ requirements in dependencies, and bundling libstdc++ can break non-bundled system components. Previously, it was based on Ubuntu 18.04 LTS, whose support period ended in April, 2023. Older systems can continue to use version 22.12, or maybe the Flatpak will work.

Well, finally I have uninstalled my Shotcut (it should be the last version). When trying to install the version 22.12, once downloaded in tar and uncompressed, I cannot copy the extracted folder (e.g., to usr/share). How can I install this version in a simple way, please? I am just a bit more than user level.

You need to be root to install into usr/share. Just extract it into your home directory and execute it from there.

I am sorry, but I have tried with my few knowledgements of Terminal, and see what I got when trying to extract the tar archive (marked in white):

You do not need to use a terminal. Simply right click on the tar file in the Downloads directory and select “Extract Here”. Then, do not move any files. Simply run Shotcut as described in the download instructions

Linux portable tar users : No install required, simply extract the archive and run it. You can drag the Shotcut folder to copy and move it wherever you want. If double-clicking the icon in your file manager does not launch Shotcut, open, and try double-clicking the shotcut shell script. Do not try to run bin/shotcut directly. You may need to install JACK from your distribution. Here is a page that lists some required packages for specific distributions.

1 Like

tar -xzf is the wrong command, for a different form of compression (gz). This form of compression (xz) requires tar -xJf

1 Like

1st of all, thank you very much to you all for answering so soon.
What is hte shotcut shell script? (I attach a screen capture with the folder, which is in the folder shotcut, which is in the folder Downloads)

That thing you have highlighted in your screenshot is the shell script. Execute that to run Shotcut.

I have executed the file shotcut (in the folder user/Downloads) and it appears this window (screen capture). I had done it before…

You did not execute it. You opened it in a text editor.

To execute it, you can open a terminal and run:

I have done it, and after several steps (worng and right), I have got to install it, but it does not start. I attach 2 screen captures.

I will do my best, but there may be mistakes in what I’m about to show you.

First, you can’t stay on 18.04 forever since support is practically dead, and it is high time for an upgrade (I wouldn’t go the dist-upgrade route and instead highly recommend you backup and do a clean install of 22.04). That being said, here is how you can proceed:

Since you appear to have installed the snap version, first remove it before proceeding with the below.

sudo snap remove --purge shotcut

Now download the correct working version for your old system here:

Assuming your download is in the Downloads folder inside your home directory and the filename is “shotcut-linux-x86_64-221221.txz” as previously described. Open a terminal and run the following commands (I always recommend to install all standalone software in the /opt folder if you want it outside your home directory but we are all different and it is just a preference):

cd ~/Downloads
sudo tar Jxvf shotcut-linux-x86_64-221221.txz -C /opt

you can just type shotcut-linux and hit the tab key to autocomplete the file name.

cd ~/.local/share/applications
sudo mv /opt/Shotcut/Shotcut.desktop .
sudo chown Baixades:Baixades Shotcut.desktop

if that fails maybe Baixades is in lowercase?

chmod 664 Shotcut.desktop
nano Shotcut.desktop

then edit the line that starts with Exec to read exactly as follows (copy and paste will work):

Exec=sh -c "/opt/Shotcut/ "%F""

Save the file (ctrl-o) then close it (ctrl-x)

Your menu should be updated with the desktop file and typing shotcut should bring up the option to launch it. However, you can also manually launch by double clicking the desktop file inside ~/.local/share/applications.

If you prefer vim (neovim) like me as your editor, replace nano with that, however I think you will be better off with nano.

Hopefully that helps!

P.S. Moving the .desktop file to the local applications folder isn’t necessary and I might get slammed for that.

1st of all, thank you very much for answering so soon.
I have done until sudo mv /opt/[…] and the program has been installed, though with another icon (see the st screen capture).

But with sudo chown […] it has stopped working, saying that “user is not valid”, and I have tried in different ways (see the 2nd screen capture).

I use a Linux Ubuntu LTS (Long Term Service) not to lose time updating and setting on my computer so often, and using computer to work. With LTS at least once computer programmers have simplified us a lot our lives. I have composed videos which I have uploaded to Youtube afterwards without updating Ubuntu, Shotcut… (Píndola de llengua 1, les vocals 'e' i 'o' obertes en català - YouTube).

OK, here is my tip with portable on Linux as it was intended. It does not require any command line work, but it depends a little on what your file manager is. Since you are using GNOME (or something based on it), it should work. After I extract the zip file to my desktop, navigate into, right-click shotcut and choose Run as a Program. Yes, that easy.

P.S. The .desktop file was made to be usable directly in its current location because it worked in some older versions of some file browsers. That seems mostly blocked now I guess because the Linux userspace is somewhat opposed to the concept of a relocatable app.

1 Like

I made a mistake when I saw an earlier reference to Baixades, assuming that was your username. My bad, sorry. Dan already gave you the simplest answer, but if you want to use the above instructions I gave and learn a little more, you can open a terminal and type:

That is your username, and you should be able to replace every instance of Baixades with that. I think your username is “user”!

Hey, I just fired up my Ubuntu 18.04 virtual machine, and there is no Run as a Program menu option. Rather, this is one of the file managers where you can simply double-click the .desktop file as long as you did not move it out its extracted location.

Again, thank you very much for answering so soon.
I have not tried the 2n way (yes, in the 1st way, Ubuntu 18.04 does not have this option) right clicking the file and running it, in the file manager, because it seems that I should run the program every time from a folder or indirectly from the dektop.
So, I have tried again the commands in the Terminal, changing “Baixades:Baixades” (“Baixades” is “Downloads”) for “usuari:usuari”, repeating them from the beginning. It has worked, although with a different Shotcut icon (the same as yesterday, as it was bad installed). I attach 2 screen captures:

Just in case, I have saved the tar file in a pen drive and the instructions to a text file and PDF (these instructions, also saved in the pen drive):
Instruccions d’instal·lació del Shotcut 22-12 (des.-2022).pdf (21.6 KB)

This topic was automatically closed after 90 days. New replies are no longer allowed.