Shotcut custom preset causing failed export

So after doing some research from older forum posts, youtube videos, and looking through the FAQ I feel as though I may have possibly come across a potential bug with shotcut custom presets. I have thoroughly tested this issue and am able to reproduce it with the exact same result each time with the exact same settings. To help make this easier for anyone who wishes to help I’ll try to post as much info about my environment, hardware and software setup, and the types of files I am using to avoid as many headaches and redundant questions as possible.

CPU - Intel i9 9900k
GPU- Nvidia RTX 2060 Super
Ram - 32GB DDR4 3200mhz

Windows 10 pro 64 bit
Shotcut 64 bit version 21.05.18
OBS 64 bit version 27.0.0

File types:
Mkv and Mp4

Now for my one and only issue, when attempting to create a custom preset in shotcut I’ve run into a persistent error that prevents me from exporting videos from an mkv format to mp4 and I’m not exactly sure why. I’ve seen other reports of shotcut crashing or failing to export at a specific time during the export but I haven’t experienced either of those issues. My problem occurs well before the video begins to export and I will sometimes get a failed export at either 16 seconds or 0 seconds. So far I am able to reproduce this failed export with a custom preset and it will fail at either one of those time codes every time with no exception. I have tried uninstalling, reinstalling, restarting, removing the appdata shotcut folder, removing all shotcut registry entries, downgrading to older versions of shotcut, using different file types, exporting to different destinations, removing the custom preset and re-adding it, trying different versions of shotcut on another computer with similar specs, tweaking the settings in my custom preset, and none of those attempts seem to fix it.

I know there can be a million different variables that can maybe cause something like this and I feel like this is most probably user error or a misunderstanding of how something in my editing pipeline works tech wise but I really like shotcut and would like to try to solve this problem whatever the cause may be. It’s a really great program and I have been reliably using it for well over a year through multiple versions without ever running into this issue before so for it to all of a sudden happen now is a little confusing to me. My final attempt at trying to fix the issue was nuking my OS and starting from scratch with a fresh install of windows 10 pro 64 bit but that was unsuccessful as well. The strange part is that I was just using shotcut last week to edit a video using my custom preset that I have been using for a 1 year plus and I didn’t have any issues. I didn’t touch it for a week and now when I come back to try to edit another video this has been my experience.

Here is an example using media info of a file that I was able to pull into shotcut and edit using my custom preset with no issue just last week:

Here are my shotcut preset settings:
Resolution - 2560x1440
Aspect ratio - 16:9
Frames/sec 60
Scan mode: Progressive
Field order: none
Deinterlacer: YADIF - temporal + spatial (best)
Interpolation: Bilinear (good)
use preview scaling - unchecked
parallel processing - unchecked

Codec - h264_nvenc
Rate control - Constant bitrate
Bitrate - 55Mb/s
Buffer size - 1500.00KiB (1s)
GOP - 125 frames fixed - unchecked
B frames - 3
Codec threads - 0
dual pass - unchecked
disable video - unchecked

Channels - 2 (stereo)
Sample rate 48000Hz
Codec - aac
Rate control - Average bitrate
Bitrate 384kb/s
diable audio - unchecked

cbr = 1
vminrate = 55M
frame_rate_den = 1000000

I’ve also disabled parallel processing and hardware encoding however I have been reliably using the nvidia nvenc encoder with absolutely no issues before this so I’m not sure if that info helps.

Now here’s the weird part, in my experimenting with my custom preset vs the built in shotcut presets I discovered that my custom preset was the issue when I selected a default preset, let’s say H.264 High profile for example, changed any setting that the default applied, saved that preset as my own, then applied it to my project. If I were to input my own settings under advanced that causes the same failed export at either 0 or 16 seconds and no amount of changes seem to help, thus my experimenting with the defaults. So far I have tried a few defaults and only changed one setting at a time to rule out other settings causing the issue with no luck.

So right now it looks like any time I attempt to either input my own custom settings and use my custom saved preset or using a default preset and saving it as my own I get a failed export no matter what. A few more important things to note is that this persists across different files, file locations, computers, export locations, and any custom saved preset. This does not affect the default presets in any way and I am able to export these exact same files with no issues at all as long I use a default preset. Even if I select a default preset and change one of the settings that it applies under advanced without saving it as a custom preset I can export any single file I pull into shotcut. It’s only when trying to apply a custom preset no matter what the settings, (even if I don’t change a single setting at all) that causes this issue.

Hopefully I was able to include enough troubleshooting info and details to get some help with this and if anyone can advise or help it would be greatly appreciated. Again, I know there can be tons of different variables for any given installation of shotcut so there’s no definitive answer to a question like mine but I hope someone can help with the info I’ve provided.


I did not reproduce your problem, but the above are computed properties based upon your inputs that got placed into your custom preset. Then, when loading the preset, they were not filtered out and overflowed into Other. I suspect the biggest problem might be the frame_rate_den. cbr and vminrate correspond directly to your video codec bitrate settings and should not be a problem, but usually the frame rate should adapt to the project’s video mode. Otherwise, it puts export into a special mode when the resolution, aspect ratio, or frame rate does not match the video mode. It is usually a good idea to edit the custom preset in the custom preset dialog to remove resolution, aspect ratio, or frame rate info.

I made a change for the next version to not put frame_rate_den in the Other tab when the preset contains frame rate.

Removing that line from the other tab and re-testing my preset seems to have fixed the issue! I’m no longer getting a failed export with a custom preset. I really appreciate your time on this and look forward to the continued success of shotcut. :grin: