Shotcut crashes when changing audio tracks and "all" tracks not functioning

Some context: I split Nvidia’s shadowplay recordings into desktop audio and microphone input tracks, which it does automatically. Track 1 is the desktop audio and Track 2 is my microphone. Usually I only need the desktop audio for a quick upload with ShareX, but when I need both I turn to Shotcut to edit the tracks together.

Issue 1: Going into the properties of a clip and setting the audio track to “all” just plays Track 1. Track 2 does not play, requiring some workaround to actually get both sides of the audio to play.

Expected result: “All” setting should play all available audio tracks overlapping

EDIT: After some goofing around, it seems that I had to change audio setting to surround sound to get this feature to work. I assumed it would play both stereo audio tracks overlapping just fine on the stereo setting, rather it seems to play only the first stereo track on all the available (2) channels and then ignores the rest if the editor isn’t set to 5.1 surround sound. Not sure how this audio editing would affect rendered and uploaded videos, however, or if it’s just the way that the project preview works. Requires more experimentation on my part, but I think it wouldn’t be too out of the question to maybe notify the user of this oddity if they try to preview more audio channels than they have set available. Below issue persists, regardless of audio settings.

Issue 2: Setting the audio track to Track 2 from “all” crashes Shotcut as of the latest version.

What I have to end up doing is splitting the audio track from the video in the timelime, changing audio on the split track from track 1 to track 2 (which then plays correctly), deleting the original video track with no audio, re-add the video clip with track 1 by default back to the timeline, then repeat for every additional clip.

It’s probably just be a problem on my end, but the crashes didn’t start until I updated from 17.0-ish to the most recent version and the “all” setting being nonfunctional has been there as long as I can remember. I reinstalled and additionally used the installer to refresh the registry entries but no luck in solving this issue.

I’m on Windows 10 64-bit, and windows event viewer blames a “libmltavformat.dll” as the faulting module for each crash. Current version as of posting is 19.01.27. Not using any advanced settings, these crashes seem to occur with a fresh out of the can installation.

Last few lines of the log relevant to the audio settings are as follows:

[Info ] [filter swresample] 4(4.0) f32le 48000Hz -> 2(stereo) f32le 48000Hz
[Debug ] TimelineDock::setSelection Changing selection to (0) trackIndex -1 isMultitrack false
[Debug ] [producer avformat] audio: total_streams 2 max_stream 2 total_channels 4 max_channels 2

Any insight into this issue is appreciated.

Windows 10 64bit, Shotcut 19.01.27 64bit
3 track stereo clip, works fine. No issues.
Just installed 19.01.27.


Track 1 (all audio)
Track 2 (game/desktop audio)
Track 3 (microphone)
MP4 created with OBS Studios.

I am able to recreate the crash in my environment. I will get a fix in the next release.

Getting the result you are looking for is tricky. A common use case for the “All Tracks” feature is that some files have 5.1 surround sound with each channel on a separate track. So when we put all the tracks together, we interpret them as surround sound. When Shotcut’s player is configured as 2 channel, the surround sound is downmixed to stereo. That is why you see the message “4.0” and why you hear all the channels when you switch to 5.1 audio in the player.

But in your case, you want all the channels to be added together, not downmixed. I had considered adding a setting for this, but I fear it would add extra complication and confusion.

In the mean time, the best workflow for you would be to create two audio tracks, add the clip twice (once on each track) and select “track 1” on one track and “track 2” on the other track. This would also have the side effect of allowing you to independently control the gain of each track.

Thanks for the help! Glad to see the crash getting resolved.

For the time being I will use your workflow tip to work around the other issue as well, thanks for the advice!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.