Shotcut crash when i drag and drop a second shotcut file into the timeline

What is your operating system?
windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
64-bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Yes, whenever i had dragged and dropped the second shotcut file next to the other, shotcut freezed for 3 seconds and shut down. I tried again many times and there is no change. I just want to put the 2 files one next to the other so if there is another solution would you please tell me so i can try it ? Thanks for your answer and your time (and sorry if there is an mistake).

Adding more than one video or audio file to the timeline is a very basic operation that many many people are doing just fine today including myself. I do not know what is going wrong for you. Maybe it has a problem with one or more of the clips you are using.

Please clarify “second shotcut file.” Does that mean a Shotcut .mlt file? From where are you dragging it? You need to be as specific and accurate as possible. Also specify your Shotcut version.

yes, both are .mlt file, i’m putting it in the timeline and dragging it from my windows documents. I just tried the reverse (putting the file that make shotcut crash in first) and all worked. But now my problem is: how can i put a file before another one without trim it ? because there is too many cut into the files, i can just “push” them in order to make place… (i hope i’m understandable and thanks you so much for your reply).

That implies from Windows Explorer directly to the Shotcut Timeline. I can confirm that does not work. The first one you drag opens it as a project. The second is added incorrectly and crashes. You need to use File > Open MLT XML as Clip… and then drag it from the Source player to the Timeline. Please try that as a workaround.

Thanks you so much !! It worked :slight_smile:

1 Like

This crash is fixed for the next version 20.09, and now you can drag .mlt files to timeline.