Shotcut crash when appling filter on source tab


#1

Hi all,

I’m experiencing a crash of Shotcut, when I apply a filter to the source window.
I don’t know if it realy make sense to apply the filter there, I found this issue during testing and finding a pattern according to this issue.

Because it’s better to let pictures (or better pictures in motion) speek, I recorded some videos. As you can see between video 1 and 3, the issue doesn’t occure everytime exactly at the same stage, but latest, when you change between “Source” and “Project” Shotcut crashes.

Some more information:

Shotcut Version number: 18.07.02

Shotcut Settings
GPU Effects (Experimental): disabled
Video Mode: 1080 29.97p
Display Method: Automatic

Operating System: Windows 10 1709

Computer Specifications
Processor: i7-3632QM 2.2Ghz
Installed Physical Memory (RAM): 8GB

Source File(s) Specifications
Codec/Extension types: (H.264 MP4)
Resolution: 1080p
Frame rate: 25 (not variable),
Bit rate: ~26Mbit/s

Some information from my eventlog (sorry for german):

Source: Application Error
Event ID: 1000

Name der fehlerhaften Anwendung: shotcut.exe, Version: 0.0.0.0, Zeitstempel: 0x5b3a03fe
Name des fehlerhaften Moduls: Qt5Qml.dll, Version: 5.6.1.0, Zeitstempel: 0x57a69379
Ausnahmecode: 0xc0000005
Fehleroffset: 0x00000000000fe19e
ID des fehlerhaften Prozesses: 0x448
Startzeit der fehlerhaften Anwendung: 0x01d416bd25c4c948
Pfad der fehlerhaften Anwendung: C:\Program Files\Shotcut\shotcut.exe
Pfad des fehlerhaften Moduls: C:\Program Files\Shotcut\Qt5Qml.dll
Berichtskennung: a3e63b69-dc0b-426d-8d96-676b0ce1025e
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

==================================

Source: Windows Error Reporting
Event ID: 1001

Fehlerbucket 1412027902262219208, Typ 4
Ereignisname: APPCRASH
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

Problemsignatur:
P1: shotcut.exe
P2: 0.0.0.0
P3: 5b3a03fe
P4: Qt5Qml.dll
P5: 5.6.1.0
P6: 57a69379
P7: c0000005
P8: 00000000000fe19e
P9:
P10:

Angefügte Dateien:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4CDA.tmp.dmp
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER523B.tmp.WERInternalMetadata.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER523D.tmp.csv
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER526D.tmp.txt

Diese Dateien befinden sich möglicherweise hier:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_shotcut.exe_b3cba479af2d8c8fd5c80bcea54b82836f8e0a_04f45527_49225861

Analysesymbol:
Es wird erneut nach einer Lösung gesucht: 0
Berichts-ID: a3e63b69-dc0b-426d-8d96-676b0ce1025e
Berichtstatus: 268435456
Bucket mit Hash: a53eed5456542cf1039887e5574791c8

=============================

Thanks in advance for all your effort!

Best regards,

Fabian


#2

Again I cannot repeat the problems you seem to be experiencing.
I tried all of the above and got no crash.

Maybe uninstall Shotcut, then reinstall it selecting to delete the registry settings.
Or maybe you have some other software conflicting.

Also, does your computer’s region settings use a comma delimiter decimal symbol? This is known to cause some problems with certain functions.


#3

I just did a complete reinstall (with removing registry) two weeks ago, but I’ll do it again…
About the comma separator, I guess we have this, but I need to double check and report back.
Thank you for your help so far!
I’ll keep posted…


#4

I just tested this on my working computer and I got exactly the same issue:

On my working computer I have Shotcut 18.05.03.
Here’s a screenshot of my location settings from my working computer (sorry for german again).


I assume, that I’ll have the same settings on my home computer, but I’ll double check that.

In Switzerland (where I live and that’s my location setting as well) we use “.” as decimal separater. Not like the Germans, as I know, they have “,”.


#5

I just reinstalled Shotcut on my home computer with removing registry settings. I also cleaned C:\Users%username%\AppData\Local\Meltytech\Shotcut before.
Still the same issue.
Below a screenshot of my region settings on my home computer (same as my working computer).

I just tried to change my regions settings go english (US): still the same issue (even after a reboot).

What I also tried:

  • GPU Effects On/off
  • run Shotcut as administrator
  • DirectX
  • OpenGL
  • Disabled Anti-Virus real time scan
  • use only one Screen on my computer (instead of two)
    still the same…

Any suggestions what I could check next?
Change my computers language to english?

Could please some other people in this forum try to reproduce the issue, it’s only 1 minute to test… would be highly appreciated.

Best regards,

Fabian

Edit: I just recorded the last steps before Shotcut crashes with Process Monitor, not sure if it helps…


#6

Aside from having [Australian English] Windows 10 Pro 1803 installed and 20Gb RAM - there’s no real difference with our PCs.
I can’t repeat the error here.

Maybe the devs can help fathom it.


#7

Did you try to put the program on Eng - US to see if it’s the same?


#8

While the above didn’t cause a crash - I have experienced a likely related crash.

See here ► [Bug] See body text


#9

I only us Shotcut with English language, but I just tried to switch to german: Same same, at least after dragging the source to the timeline and then switching between Source and Project back and forth Shotcut will crashed… (as usual).


#10

I reproduced this bug on both Windows and Linux, and I am working to debug it now.


#11

Thank you very much, it’s highly appreciated!


#12

This is fixed for next release v18.08. It was a regression since v18.05 with introduction of keyframes. Thank you for the good report. I was noticing a general instability that was being a bit difficult to pinpoint, and this helped a lot.


#13

Excellent!!
Really looking forward to 18.08!
Is the cause of this bug somehow also related to the following issue?