Shotcut can't playback video smoothly

I have many hour long videos I need to edit, most of which are 1920x1080 at 60fps, 40Mbit/s. Attempting to play these videos in shotcut is a nightmare, they will not play smoothly until the eighth time playing the same small portion. I simply can’t edit the video when I can barely tell what part I’m at. I haven’t even edited the videos, playing the video in timeline or project source, the playback is not smooth whatsoever.

I’ve looked at other threads, it’s suggested to try preview scaling and/or storage proxy. Neither work - I have the footage stored on network based storage, copying them to local NVMe SSD storage didn’t help. Setting preview scaling to 360p has a noticeable impact on quality, but still doesn’t help (again off the SSD). Attempting to playback the footage also hits my CPU with a 50% load.

I really can’t imagine this is the intended experience for the software, if I could get a hand sorting this issue out, it would be greatly appreciated.

System information:
OS: Windows 10 21H1 Build 19043.1165
Shotcut version: 21.10.31
Nvidia Driver: 472.12

System Specifications:
CPU: Ryzen 7 2700X - 8C/16T
RAM: G.SKILL Ripjaws V Series (2x16GB@3200MHz)
Mother board: MSI X470 Gaming Pro Carbon
Video Card: Gigabyte GTX 1080 TI 11GB
Power Supply: EVGA 650W - EQ (80+ Gold)
OS Drive: Samsung Evo 970 - 1TB NVMe M.2
2nd Drive: Samsung Evo 970 Plus - 1TB NVMe M.2

Edit: Disabling real-time under Settings fixed the issue. Playback is now smooth.

Does this include using both at the same time?

60fps is a lot of frames. Some processors are simply not fast enough to be real-time at 60, but might be fine at 30/25/24.

What is the video format? If it’s anything that ends with .MTS or .M2T or .TS, then part of the issue is probably due to the format. “Convert to Edit-Friendly” can usually improve that experience. Although, I would have expected proxy to improve speed as well. I’m surprised it didn’t.

Settings > Display Method can sometimes give very different performance speeds with OpenGL vs DirectX vs ANGLE. Worth trying them all.

Also, is Settings > Real-time turned on?

Yes, mentioned that on the following line.

The playback only puts a 50% load on my CPU, it has a lot more room to work with if it’s able to.

mp4 container originally encoded with h264 NVENC. Here’s VLC’s codec information tab on the video.

No difference between OpenGL and DirectX, however disabling real-time fixed the issue. It doesn’t put nearly as much of a load on my CPU and is as smooth as butter. Thought I had tried this setting before, I suppose I didn’t. Thanks for the help, going to make editing a lot easier.

Tente mudar o formato do video para MP4,AVI, WMM, etc, vai experimentando. E o fps, use outro. Clique na area de trabalho com o botão direito, vá em configuração de exibição, procure configurações de elementos graficos, veja se esta marcado o seu drive de video. Outra opção é limpar todos os temporários do sistema, aponte para iniciar e digite %temp%, exclua todos, as vezes o SHOTCUT (não sei porque), ele não gosta do sistema cheio de temporarios, frescura dele,rs.