Shotcut barely using CPU, RAM, and GPU

I have a Ryzen 7 5800x and GTX 1660 with 16 Gb RAM. This should be more than enough for video editing, yet Shotcut barely uses any of the resources available (10% CPU, 2 Gb RAM, and 5% GPU), causing exporting to take ages.
A short 6 minute video I’m trying to render at 720p is taking over an hour to finish. It’s not even complicated, having minimal editing/effects.

Does anyone know how to make Shotcut use more resources?

I think I have the same question , any body please?

We are still improving Shotcut’s ability to take advantage of multicore processing.

In the “Advanced” export options there is an option for “Parallel Processing”. If you check that option, Shotcut will try to do more things at the same time. If you choose to try this, be sure to check your output to make sure everything looks good. Also, infrequently someone will report a problem and then the problem goes away if they uncheck parallel processing. So keep that in mind.

Also, the speed of the drive that contains the media can be a factor. Make sure you have moved all of your clips onto your fastest internal drive (hopefully SSD or NVMe).


This seems to have sped up the process by a little.
I’ll be waiting for multicore processing, thank you for the information :slight_smile:

Anyway for a 6 min. video in 720p it is really a long time when rendering takes more than 1h. Could you show us your timeline and filters used just to check what could cause that delay? My system is not really stronger (apart from 32 GB RAM) but for 6 min video in FullHD it would usually take 10 - 15 min. to render. I have to admit its very much depending on your filters (some filter are really demanding, anti-shake, sharpening e.g.) and also the export codec and the input codec of your clips do matter.

You marked it solved . did it really solve your problem ? How did you see it solved your problem? How did you monitor it?
Not sure in my case it worked

After turning on the dual processing, I re-rendered the video and it cut the time taken in half.
I also checked in task manager and saw it was using 50% of my CPU and 5% more GPU on average.

Thanks this is my sytem information : Processor Intel(R) Core™ i7-10700KF CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)

So I change the number ?

No. By default Windows uses all the cores that your processor has. The only use for this BIOS feature is to REDUCE the number of cores (e.g. for debugging or performance measuring purposes).


That’s not it, no. You need to go to the export settings in Shotcut itself. Click on “Advanced” and then tick the box that says “Dual processing”. That did it for me.

Please see this. I do not have that option

He meant the “Parallel Processing” option (which you appear to already selected).

Can you share a screenshot of your export settings? 1 hour for 6min 720p export is unexpectedly long. What codec are you using?

Like Elusien said, I meant parallel processing. (Mine is set to a different language, so I used a different word. My bad.)

I also turned on hardware acceleration, so that might have improved performance.

Be wary of using Hardware Encoding. Most encoders cannot handle VP9, if you are set on that. Also, unless your graphics card is one of the more recent ones you are likely to end up with poorer quality videos that take up a lot more disk space, as they are designed more for streaming in real-time, rather than recording high-quality videos.

This topic was automatically closed after 90 days. New replies are no longer allowed.