Shotcut 60fps problem


#1

So far shotcut has been wonderful, but when I tried 60fps on my project, it lagged a lot and forced me to shut the conputer down. Even when I got to see the job list (took 5 to 10 minuted just to pop the window up), it said 0 percent.

And it also says it’s completed, and I check the video file details, it tells me it’s 661 fps but it’s 30fps and it takes only 17 minutes which was short, and explained why it was only 30fps. Other than that the lag is not really a problem, but the 661 fps label is just nonsense.

This was on the latest version at this time of this topic being posted.

This occured on one specific project I made.


#2

Not enough information:

  • OS
  • Shotcut version
  • project resolution
  • export settings
  • What tells you 661 fps and how do you know it is 30?

Based on the description of the lag and time to open the job list, your computer might be low on memory for this resolution/framerate/project complexity. More than likely, it was swapping RAM to the hard drive.


#5

How do I deal with the low RAM issue? Is there a way for shotcut to use less RAM, or a way to have shotcut put less street on the computer and spread the “work” to a longer time interval, this containing enough RAM?

I can tell because my monitor is limited to 60fps, and just by visually inspecting it, it is clearly 30 fps. And the file size was 219MB and around 4 minutes long, so no way can it be near 661 fps.

Shotcut version 19.04.30

Export settings on 1080p 60fps, and there are varying resolutions, with different picture sizes and video sizes, and formats.

500 view video 2.0 - Repaired.mlt (602.1 KB)


#6

I also do not want to show you the video itself for privacy reasons, but I will show you the details in a screenshot.


#7

It generally tries to use as little memory as possible. Of course, higher resolution requires more RAM. Other than that:

  • Ensure Settings > Realtime is On (it uses more threads when off)
  • Use fewer tracks
  • Avoid using Size and Position or Rotate and Scale filters against a very large digital photos by downscaling them some in an image editor
  • When exporting, turn off Parallel processing in Export > Advanced > Video
  • Do not change the resolution, aspect ratio, or frame rate in Export > Advanced > Video

OK

Yeah, probably so. It was just indicated wrong. With that said, I have not experienced this and neither is it a known problem.

[500 view video 2.0 - Repaired.mlt]

I see your project is set for 1080p 25 fps. Immediately after you open a project, the top left corner Master is selected and Properties reports this. You should set a 60 fps Video Mode in Settings or the New Project view if you want to create a 60 fps project. Exporting to a higher frame rate is generally useless as it does not take advantage of a source with a higher fps. It renders to the project video mode, and then resamples to the export settings if changed.

You should try to export your project using the Export defaults but turn off Parallel processing. Once you get something out correctly, then you may experiment with changing Export settings (other than resolution and fps) if you feel the need.


#8

Are you talking about Realtime as in the Task priority in Task Manager? Or in shotcut? I do not know where Realtime is.

As for parallel processing, what exactly does it do when it is on?

The reason I set it to 60fps is I have 10x and 20x speed of 25fps sources, which increases the framerate dramatically (25 fps x 10 = 250fps) . The size and position effects move and change the size of the video themselves, not alter the framerate of the video source.

I also have the old film effects which I need to have at 60fps. I had had success with 60fps with only 30fps video sources, which the shotcut effects are 60fps, but the video sources are only 30fps.

I also have tried setting qmelt and shotcut.exe to high priority in Task Manager. It did speed it up a little, but the problem still existed.


#9

Ok just exported it again, and now there’s another problem. It is in 60fps, but that’s when shotcut crams everything to 60fps, like it used to be around 4 minutes long, now it is down to 1:38 and it is basically sped up to match 60fps. File size is 118MB, and it does say 60fps.

I do not want the sped up version of my work. I need it to be the same 4 minute project and have it 60fps.

What I meant by my success in previous projects I meant to say that my previous projects were all 25fps but the 60fps sources were all okay, and the videos exported were all the same original time, not sped up or slowed down in any way, except if I wanted some to.

I think those projects I made were in the same version 19.04.30


#10

Ok just realised, I added the audio file first, and the note said, if I add anything that is not a video file, it will default to 1080 25fps.

Either way, is there a way to change the default to 1080 60fps even though I added the audio file? I really do not want to put the work into doing the project all over again and copying all those tracks one by one onto a new project.


#11

For new projects, change Settings > Video Mode to something. The 1080 25 fps is for Automatic, as explained.