Shotcut 23.05.14 win64 Qt6Gui.dll error on startup

OS: Windows 10 (64 bit)
Version: Win64 23.05.14

On starting, no GUI appears, but WIndows Error Dialog with the text:-

“The procedure entry point SystemParametersForDpi could not be located in the dynamic link library C:\Program Files\Shotcut\Qt6Gui.dll”

Have tried also the portable version, with same results. Have also searched the drive for all QT6 dlls and checked if they are already loaded, and they are not. Only Qt6 dlls are in the shotcut directories.

Same results with 23.04.20.

Don’t know how to produce logs ATM, sorry

This is the location for the log file.
Just drag & drop that file into the reply window.

The logs aren’t produced - nor is the %APPDATA%\Local\Meltytech\Shotcut directory created.

To be clear, I tried first with a windows install of 23.05.14. This failed as described.
I then dowloaded and unzipped the portable 23.04.20. Same result.
I then backtracked to the zip file for 22.12.21 and this worked fine, except it didn’t have the feature set I needed…(Want to be able to rotate 180 video clips).

So, to produce fresh logs for the error I reported with 23.05.14, I did a Windows uninstall of Shotcut, then to be sure, deleted the reg key branch HKEY_CURRENT_USER\Software\Meltytech\Shotcut and renamed the log/cache directory %APPDATA%\Local\Meltytech\Shotcut to _NOT_Shortcut.

Running either the shotcut.exe from either of unzipped 23.05.14 or 23.04.20 didn’t re-create this directory again. But it was recreated when I ran the old 22.12.21.

Looks like a QT6 dll issue. But surely others must have the same problem on this platform!?

Hope this makes sense and Thanks everso in advance :slight_smile:

Qt is faililng to load because it can not find the standard Windows function “SystemParametersForDpi”.

This function was added in Windows 10, version 1607

Is it possible that your version of Windows 10 is older than 1607? That would be from July of 2016? Can you go into your Windows settings and find the exact version of Windows (including the build number)?

Looks like it’s an old version. It keeps trying (without success) to update.

OS Name	Microsoft Windows 10 Home
Version	10.0.10586 Build 10586

Microsoft Windows [Version 10.0.10586]


OS Name:    Microsoft Windows 10 Home
OS Version: 10.0.10586 N/A Build 10586

I’m afraid Shotcut 23.05 is not compatible with your system. You need to either upgrade Windows, or keep using 22.12.

Thanks for your help.

At least we understand what the problem was now.

I have other options too.

From the little I’ve seen, Shotcut looks a great of multi-platform open source ptoduct. Great Work!