Shotcut 21.03.21 hands regularly for 1-2 seconds

What is your operating system?
Linux Ubuntu 18.04

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.03.21

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
Previously I used 20.10.31 Shotcut. After installing 21.03.21 shotcut regularly hands/freezes for 1-2 seconds. Sometimes it’s not repeatable but for example it always freezes when stwiching between keyframes and timelines (I have them on two different tabs in the same window). It looks like that new shotcut requires much more processor/graphic power. But why? If I look on CPU history processor is never used up to 100%, max. to around 50%.

I do not experience this, but we made a big upgrade to our GUI library Qt and had to change to some new APIs as the old ones deprecated. You can read more here:

https://shotcut.org/blog/

Some UI parts (player, Timeline, Filters, & Keyframes) depends very heavily on OpenGL, and the way it is used in the new APIs in the new library might be slower on your system’s hardware and driver.

I tried both software and OpenGL rendering and more or less it’s the same. Which OpenGL do you use?

From the Application Log

[Info   ] <Mlt::GLWidget::initializeGL> OpenGL vendor "Intel" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL renderer "Mesa Intel(R) UHD Graphics 630 (CFL GT2)" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL threaded? true 

Please be aware that the software OpenGL does not work with the nvidia binary-only driver and possibly some other non-Mesa-based AMD driver.
Now that I have done some direct comparison testing of your description “stwiching between keyframes and timelines” it does seem a little slower, but not much. Certainly not enough to be a priority, and honestly I do not think I would know how to improve it.

Well perhaps it some kind of driver/kernel etc. issue. On my computer it’s not usable as switching takes 1-3 seconds. Moreover also moving elements from one track to another is very slow.

I use ryzen 7 3700u thus it should have quicker graphics than intel 630…

Well, I updated kernel and ubuntu and still this problem exist. Moreover it doesn’t look like the problems with performance. When shutcut freezes for 1-3 seconds, I can have ex. Firefox run in parallel and I can browse Internet without any visible delay. Also when monitoring processor performance it’s used max. up to 50%. Hmmm…

Have you tried changing Settings->Display Method?

Yeah, I worte previously that I’ve tried both software and OpenGL rendering and it’s the same… :frowning:

Please report the OpenGL lines from your log as I did.

I hope you mean this part:

[Info   ] <Mlt::GLWidget::initializeGL> OpenGL vendor "X.Org" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL renderer "AMD RAVEN (DRM 3.35.0, 5.4.109-0504109-generic, LLVM 10.0.0)" 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL threaded? true 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL ES? false 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL maximum texture size = 16384 
[Info   ] <Mlt::GLWidget::initializeGL> OpenGL maximum viewport size = 16384 x 16384

Any possible suggestions?