Shotcut 19.12.31 linux: no "Text: simple" filter?

I am using shotcut 19.12.31 on Gentoo linux and I am experiencing the problem that the “Text: Simple” filter is not available.

I read this posting:

It appears that the “dynamictext filter” is not available in mlt. So, I tried:

user@computer ~ $ qmelt -query filters

A long list of filters is produced, but not “dynamictext”. For MLT, I used the following settings:

root ~ # emerge -pv mlt

These are the packages that would be merged, in order:

Calculating dependencies… done!
[ebuild R ] media-libs/mlt-6.20.0::gentoo USE=“ffmpeg frei0r gtk jack opengl qt5 sdl xml -compressed-lumas -debug -fftw -kdenlive -libsamplerate -lua -melt (-opencv) -python -rtaudio -ruby (-vdpau) -vidstab -xine” CPU_FLAGS_X86=“mmx sse sse2” PYTHON_SINGLE_TARGET=“python3_6 -python3_7 (-python3_8)” 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

I guess that I need to enable some USE flag, but which of these flags has relation to the “dynamictext filter”:



Looks like you are using a custom build of Shotcut, which is not fully supported here. This filter depends on either Qt or gdk-pixbuf.

I do not recognize these flags as part of MLT’s configure script. If they are for gentoo emerge, you might have better luck asking on a gentoo forum or list. You might get lucky that someone here is using gentoo, but it is rare coming from someone who has read nearly every message here.

From emerge (with some editing for readability)

Configuring source in /var/tmp/portage/media-libs/mlt-6.20.0/work/mlt-6.20.0 …
Found gcc version 9.2.0
Configuring framework:
Configuring modules:
Configuring modules/avformat:
Configuring modules/core:
Configuring modules/decklink:
Configuring modules/feeds:
Configuring modules/frei0r:
Package frei0r was not found in the pkg-config search path.
Perhaps you should add the directory containing `frei0r.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘frei0r’ found
Configuring modules/gtk2:

  • Libexif found, enabling auto rotate
    Configuring modules/jackrack:
    Configuring modules/linsys:
    Configuring modules/lumas:
  • not explicitly enabled: disabling
    Configuring modules/motion_est:
    Configuring modules/ndi:
  • NDI SDK not found: disabling
    Configuring modules/normalize:
    Configuring modules/oldfilm:
    Configuring modules/opengl:
    Configuring modules/plusgpl:
    Configuring modules/qt:
  • Libexif found, enabling auto rotate
  • Qt version 5.x detected
  • Include directory: /usr/include/qt5
  • fftw found, enabling lightshow
    Configuring modules/rubberband:
  • rubberband not found: disabling
    Configuring modules/sdl2:
  • using SDL version 2.0.10
    Configuring modules/videostab:
    Configuring modules/vmfx:
    Configuring modules/vorbis:
    Configuring modules/xml:
    Configuring mlt++:
    Configuring swig:
    GPLv3 license used

Source configured.
Compiling source in /var/tmp/portage/media-libs/mlt-6.20.0/work/mlt-6.20.0 …

In the above list, is there any indication where / why the “dynamictext filter” might be impacted?


The plus module is disabled by configure. It lives in the plus module.

Aha! I checked the EBUILD, and on Gentoo, “plus” is enabled if the “fftw” USE-flag is set!

For the impatient:

root ~ # echo “>=media-libs/mlt-6.20.0 melt fftw” >> /etc/portage/package.use
root ~ # emerge -v mlt
root ~ # emerge -v shotcut

and: the “Text: Simple” filter becomes available in shotcut 19.12.31 on Gentoo linux! It’s a kind of magic!


This topic was automatically closed after 90 days. New replies are no longer allowed.