Shotcut 19.07.15 is not changing the base frame rate to match an opened .mlt file

After successfully working on a clip with a frame rate of 29.97 fps, I opened a saved .mlt of another clip I was working on and it had a frame rate of 25 fps.
Something was very odd, the freshly opened .mlt file was not as I left it when it was last saved. It took me a little while to work out that Shortcut 19.07.15 had imported the .mlt at 29.97 fps, not 25 fps as it was when I last saved it.
To check this, I closed Shortcut and re ran Shortcut, changed the video mode to 29.97 and opened an .mlt of a clip on in 29.97 fps and everything was fine. Then I opened another .mlt file of a clip in 24 fps and Shortcut opened the clip in 29.97 fps, not 24 fps as it should have been.
Cheers

Step 1. Set video mode (For every new project)
Step 2. Import File(s)
2019-07-31_07-39-18

If you previously set the video mode to 29.97, Shotcut remembers that setting for your next project. Need to verify the video mode before every new project.

I just tested, and it is working fine for me. The Settings > Video Mode selected menu item will not change when you load a project to show the project’s frame rate. You need to get the Properties of the Timeline by selecting the “Master” cell in the top, left corner. In the screenshot below I have my Video Mode as 720p50, the MLT XML shows 30000/1001, which is equivalent to 29.97 shown in Properties. I also tested switched between projects of different frame rate within the same Shotcut session. I need evidence and more detailed steps to accept this as a bug.