Sharpen Filter makes the video run slow

Why is it when I add a Sharpen Filter to a clip, it makes it play back very slowly and choppy? Can this be avoided?

I am using version 18.03.06. Removing the Sharpen Filter restores the playing speed, and it only does it on the clip with the filter, not the whole track.

If I go ahead and export the project, it does play at normal speed.

The speed depends on the power of the computer you are running Shotcut on, so I’m afraid to get a better playback in the preview pane you’ll need to upgrade it. Whe you export, Shotcut has all the time in the world, so it doesn’t matter if your machine is a tad slow.

That was the case for sure until I did exactly what you just said: Upgraded my computer to a fast SSD.

Now, back to my question: This only happens when I use the Sharpen Filter. The rest of the time it runs great, and I love using Shotcut. I let it work on it OVERNIGHT, and it still does the same thing. I also saved the project, came back to it later, and gave it plenty of time again. Same thing until I exported it.

Also, it took no longer than usual to export the project to an MP4 when this was occurring. So, I cannot believe that the Sharpen Filter is just so bandwidth intensive that it is supposed to do this, when everything else runs fine, if this is what you are suggesting.

Are any of you others experiencing this same thing?

I don’t have the answer but would rather to ask you, what do you see as the advantage of using Sharpen filter in Shotcut compared to applying, perhaps, the same filter in a video player or TV setting?

I have tried the sharpen filter on a clip using my Surface pro. Spec:

	Intel Core i5
		Cores	2
		Threads	4
		Name	Intel Core i5
		Code Name	Skylake-U/Y
		Package	Socket 1168 BGA
		Technology	14nm
		Specification	Intel Core i5-6300U CPU @ 2.40GHz

		Type	DDR3
		Size	4022 MBytes
		Channels #	Dual
		DRAM Frequency	931.3 MHz

Not a very powerful system. The clip is 30 seconds long and runs in Shotcut’s preview pane in exactly 30 seconds.

I apply the sharpen filter to the entire clip and have the option set not to drop frames. Modifying the Amount and Size parameters it takes between 3 and 4.5 times longer to run in the preview pane.

 50%  x  50% takes 3x longer    (default)
100%  x  50% takes 3x longer
 50%  x 100% takes 4x longer
100%  x 100% takes 4.5x longer

When you say it takes longer with the filter applied, how much longer does it take? What are the filter parameters you are using? Does it start out fast and then slows down or is it slow from the beginning? Just saying it is slow and choppy doesn’t give anyone an idea of how badly it is performing. Maybe there is someone on the forum who has a similar spec system and it works perfectly for them. Or maybe they have problems too. Either way it may help work out if it is really a problem…

It is normal that Sharpen is slow. That’s just the way it is unless you use GPU Effects, which is not supported. The slowness is due to CPU processing and not I/O bandwidth. The SSD is just taking a little edge off of the overall processing time by reducing latency thereby giving the CPU more time for each frame. It is possible the CPU version of this filter will be optimized better for performance in the future, but I am not promising anything.

Okay, that explains it, Thanks! I can live with that. I normally don’t need Sharpen anyway, just on a few clips. Just setting the camera for the sharpness I need usually covers it.

Thanks for the help, and thanks very much for the great software. I love Shotcut!

No, I don’t normally use Sharpen. Just wanted to know if this is common, or if there were something I could do about it.

Thanks for responding.

Thanks for the response. It does not seem to matter how I change the parameters, or if I leave them at default. Runs slow and choppy the whole time at the same speed. Removing the Sharpen filter fixes it.

Shotcut Leader has explained it for me, and I’m good with that.

This topic was automatically closed after 90 days. New replies are no longer allowed.