Shake preset doesn't work


#1

Hi!
If i try to add shake preset (tried both), the screen turns black both position and size numbers go wild: -13440 × 5400 for a 200 × 150 image.


#2

Used both shake presets.
250%20spin4


#3

Check the comments of the youtube video. My problem is not an isolated problem.


#4

Never really played around too much with the preset, but after a bit of doing so, I think I discovered what you’re talking about. But quite hard to describe.


#5

Yea kind of like this, however I cant get the initial shake you have


#6

I’ve just experimented with it out of curiosity and I can’t reproduce what either of you describe/show. Both presets and the shake preset I made for myself before the bundled ones work fine for me.
It’s only intended to be a one second shake and that’s exactly what I get, no bkackouts. Is it being combined with any other filters?


#7

I think it comes from trying to position after applying the preset, which doesn’t work well if not at all.

And the size adapts to the set video mode when using the preset. The preset only works with Size Mode, Horizontal Fit & Vertical fit. Not touching anything else, it works like a charm. It may work great with just a 1 track video, but doesn’t work with 2 video tracks if you try and position a smaller graphic where you want that graphic to shake.
shotcut_2018-11-23_10-10-10

Here is the challenge, 2 track video. Place this image in any of the corners of the video and just have this image shake. The image is 64x64 and goes on V2. I can’t find a way to make this shake over V1’s source, outside of Size Mode, Horizontal Fit & Vertical fit limitations. I’ve been working on this what I thought was a simple task for 2 days.
g64

After the Shake preset is applied, moving from the center, in any direction, gives you this.

Edit: I even tried using the numerical fields to set the position or size, and after you enter one number, then go the next, it glitches out.

Tried with these Shotcut versions: (Same results)

  • 18.09.16
  • 18.10.08
  • 18.11.18

Audio Visualization Filter
#8

Yeah it does the same for me when I try that. Normally if I set a size and position filter on something then put that in a second size and position “window” it appears as a virtual screen. That doesn’t seem to work on this combo.
Only way I can get it to work is to position the small image in position on a still image of the same pixel resolution of the video and export as a png - then it moves as expected.


#9

I was thinking that would work because you are not moving the the actual box, but I had not tried that yet.


#10

Both Shake presets work with 2 tracks.

S%20and%20P%20Shake

image


#11

I had the same thing too @sauron, but when I added video on v1 instead of background color, is where the problems take place. Post #2, I had the same type of gif you did.

Can you move that 200x200 image to any corner and make that happen?


#12

For the gif I used the R&S filter to scale the image to 35% then added the S&P with shake. The range of motion is limited.

If you want to move the image to any corner you need to apply an S&P filter to the miage then apply another S&P filter with shake. In that order. Then you can size and move the image anywhere you want using the first S&P filters controls. If you touch the shake controls ii will go wonky.


#13

I tried your steps. Still didn’t work. I’m not needing this for any project, just trying to learn, or perhaps find a work around until it’s fixed.

Step 1 as you outlined, apply filter #1, works great here.

Step 2 as you outlined, apply filter #2, image not visible now.

Applied Scale preset, image still not visible.

The true problem is when the image is not centered to the video mode is what makes things not work.


#14

Even tried R&S first, same results.




#15

Just discovered how easy it was to use keyframes to make my own shake. Never really took an interest in them before. I don’t care about any presets now, lol.


#16

My bad. The image needs to be full size in order for my steps to work. If you have a 1920x1080 video mode the image needs to be the same resolution as the video mode.


#17

That’s exactly what I found when I tried @Hudson555x 's challenge. If I place the square in the corner of a 1920 x 1080 clear png it works, but moving it there with S&P doesn’t. It also fails to work with my own shake presets which puzzles me, because it seems to work OK layering S&P filters for other techniques.


#18

I’m not a programmer, so I may have this all wrong, but I possibly spotted a few defects in the code.

So I copied & renamed it. Edited ( with Notepad ++) what I thought was bad. Just putting a space between = and - on two lines. It took me an hour to figure out there are two locations for the preset, affineSizePosition being the one I didn’t know about while I was trying to figure out why the one I put into movitSizePosition wouldn’t show up in the presets.
Shake Presets.zip (1.4 KB)

So I finally got the Shake effect (Scaled) to work. It still acts weird if you even attempt to manually position the effect, but I was able to use the Scale/Rotate filter to accomplish what I wanted to.

2018-11-26_17-09-44


#19

This is not required according to the parser source code.

affineSizePosition … movitSizePosition

Movit is the name of the GPU Effects library while “affine” refers to the MLT affine filter, which runs on the CPU. Some of the filters have a Movit (GPU) and non-Movit (CPU) implementation that are different in their detail and parameters. So, they have different UI and preset files in Shotcut while having the same name and parameter labels to create a superficial similarity.