Several bugs when installing via software manager in linux mint

When installing via Software Manager in Linux Mint, Shotcut has a bugs.

  • the bug is related to this
  • In Software Manager the program can not be found in “rate program”-community.

But instead the log is: /usr/bin/nice: « /app/bin/qmelt “No file or folder found”.
The app-folder does not exit in Linux Mint.

When installing via there no bug.

Linux Mint 18.3 “Cimmamon 64bit”
Shotcut 18.08.14

What is this build? From which repository? When I search on I get no results:
Repository - Linux Mint

Just like the thread you mentioned, we do not make the build you are trying to use and do not take responsibility for it. We have enough work to do let alone fixing other people’s builds, but if they come to me, I can probably provide some hints. Please try to figure out the source of the package and where to report problems for it.

Thanks for the reply…

I don’t know from with repository in come from in Linux Mint Software Manager. I think you are right, the problem is a the software manager.

But it is a shame that installing from Software manager is not working, because Shotcut is a fantastisk program. When the novice user can not get to work from Software manager they will blame the Shotcut developers.

Do you recall adding any repos? Do you know how to see if is included?

No I have not tried any faultfinding. I just hik install in the Program Manager and the installer does not report any error.
But shotcut is not working when installing from Program Manager.

OK, that screenshot shows it is the Flatpak from FlatHub. I will let the maintainer know about this thread.

What’s the output of:

$ flatpak --version

What happens, if you run:

$ flatpak run -v org.shotcut.Shotcut

I’ve got a similar bug: I’m on Linux Mint, I installed Shotcut via Flatpak and when I save (for example to home/Videos folder) it actually saves to /run/usr… subfolder. What should I do?

1 Like

Thank you for the warning, Carsten: I’m new to Mint (using same version as yours), since I gave up Ubuntu Studio two months ago when I understood it was predeceased.
I also installed the same Flatpack package, when I discovered the regular package was not compatible, but I did not feel it well, and I never dared to work on a project on Linux with it…
Thank you for warning the maintainer, Dan!

1 Like

@attilio Please provide the information that peter asked for in his comment directly above yours!

@attilio This sounds like you’re using an old version of flatpak. You need at least version 0.11.4 for file saving to work.

@shotcut I added a version check to the flatpak to prevent installation:

1 Like

I’m using 0.10.0, the default version for Linux Mint 18.3.
I solved my issue uninstalling from software manager and downloading the portable version instead. I wonder whether it will automatically upgrade or I need to manually download the latest version at every release.
Anyway thanks for your answer.