SD MPEG 2 export preset still does not work

I have Shotcut version 22.12.21 running on Windows 10, I use this because external monitor configuration was ceased after that. My Desktops are 1 x HP Z800 with 72gb DDR3 memory, and an Nvidia GeForce GTX 1060 6gb GPU plus 1 x HP Z840 with 64gb DDR4 memory, and an Nvidia Quadro M6000 12gb GPU.
I have tried many times to export MP4 phone footage using the MPEG 2 standard definition preset, only to find that the process stops around half way through.
I know that many people will say that MPEG 2 SD is an outdated format, but try telling that to all my customers who still have DVD players.
I end uo exporting the timeline as an MP4 file then using Premiere Pro to export as an MPEG 2 file.

Shotcut version 22.12.21

We are not making fixes to that version, so not accepting bug reports about it.

external monitor configuration was ceased after that

It still works with Blackmagic Design’s Intensity or DeckLink peripherals.

There is no “SD MPEG-2” export preset. There are “MPEG-2”, “DVD (SD PAL)”, and “DVD (SD NTSC)” presets. All of these are working for me in the current version.

I repeat the same as dan, there is no “SD” mpeg-2, and I used mpeg-2 to export on the version that you are using, just works fine for me.
Intel HD 2500, 6gb ram, i3-3220t… It’s an old hp machine.

Please ignore the SD part of the description. I only put it there to differentiate with HD versions of the MPEG 2 format.
Can I ask how long were your MPEG 2 clips? In my case they were over two hours.
Did you use the advanced settings? If so, what custom settings worked for you?
I don’t use the DVD presets because they make vob files, and I prefer mpg files.

I have Intensity and Decklink peripherals on each of my workstations, but I only have one HDMI input on the TV I use as an external monitor. I could use an HDMI switch box, but life is complicated enough.

1 hour 35 minutes + 54 minutes


Lowering down a few pixels, mpg, also the default works for me.


Thank you for your very concise reply. I think I have solved my problem, it is because I was using the second MPEG 2 preset in the list instead of the first. I successfully made a short test clip yesterday so please consider this problem solved, and I’m sorry for the trouble I’ve caused. Shotcut is great!!

1 Like

Yes, i also used the first preset, not checked the second one. One small thing, I was not using hardware encoding.