Scroll bars for filters

On some filters, the scrollbars do not have enough action.
Part of the dialogue area remains inaccessible

https://streamable.com/dvcum

I just had a look at the Color Grading filter you used to see if I could get it to work, only to find it works perfectly for me!

I’m still using version 19.01.27, what version are you using. If it is a later one maybe one of the other guys could see if it works on the latest version for them.

Also, what is the resolution of the screen you are using?

Yes that’s right, I forgot to specify the configuration:
iMac 20 inches
OSX 10.11.6
Resolution 1344 x 840
Shotcut 19-04-30

I did a test with the standard resolution set by Apple for this monitor (1680 x 1050) it’s the same

I noticed this with the Compressor filter. If you make the window for Filters smaller then the scroll bar that appears won’t go down all the way to let you see the numbers in the Gain Reduction meter nor the “About dynamic range compression” link.

Related to this, if you have have the Filter window with the scroll bar and you use the mouse’s scroll wheel to lower or raise the values on a parameter, when it hits the limit on either the low or high side the scroll bar will start to move even if you have the mouse still in the area of the parameter. It’d be nice if this could be tweaked so that the scroll bar can only be affected if you the mouse away from the parameter value.

This cannot (or should I say will not) be tweaked because it is behavior inside Qt Quick. This is very high level GUI code you can see by looking at one of the ui.qml files. Maybe a higher version of Qt will fix it, but I am holding off because new versions require newer versions of macOS, and I want to keep all on the same version.

As for filters not scrolling enough, I do look at this and adjust the height in the ui.qml file, but there are are N filters x each OS (and sometimes text size). I will increase the width of Color Grading and the height of Compressor.

Thank you Dan,
I modified the file Shotcut.app/Contents/Resources/shotcut/qml/filters/color:
line 29 width 455 -> 655
line 30 height 280 -> 350
The result is OK

https://streamable.com/o6xbf

I just noticed that on some filters the horizontal scroll bar does not even appear while there is still content on the right.
By detaching the filter window, the content appears.

https://streamable.com/hi9ul

Rather than modify all the ui.qml files with fixed values, can not we calculate the necessary width and height according to the elements present in the window ?

I modified line 175 of the file
Shotcut.app/Contents/Resources/shotcut/qml/views/filter/filterview.qml
like this:

Math.max(150 + filterConfig.minimumWidth, // (rajouté 150 +)

It seems to fit all filters, but probably on the other systems there will be a large margin at right

@shotcut

New version Shotcut 19.06.15
I reviewed all video filters, there is still the filter “timer” whose vertical scrollbar is insufficient.
Changing the “height” parameter in the ui.qml file from 350 to 400 solves the problem on mac OS X

Thanks, this is fixed for the next version.