Screen recording 💭?

There are some topic seems related to this,
it seems ShotCut could do this,
but I am not sure.

Could any nice one tell me the correct steps to record screen using ShotCut :grinning: ?

The steps I’ve tried (for screen recording) as below:
Step1. File > Open Other > Video Input = screen-capture-recorder > [OK].
there was no recording range selection like a screen recording software.

Step2. I saw the timestamps changing quickly below the ‘Source’ tab,
then I saw the error message: Fail to open dsShow…
and I don’t know how to stop this.

Step3. File > Open Other > Video Input = HD webcam > [OK]
then I saw the error message: Fail to open dsShow…
also I don’t know how to stop this.

I must miss something (or ShotCut cannot do something),
and I don’t know where to setup a correct ‘screen-capture-recorder’.
this seems a complex task (not easy to understand what is ‘Open Other’ )
if you have a guide link please give me one, Thank you :slightly_smiling_face: !

I run on Windows and use Sharex ( for screen captures, as do several other of the reular forum members. To my mind it’s better to use software that is specifically designed to do something (like screen capture) than one where the feature you want is not the core function of that software (like a video editor). It is more or less guaranteed to work and have more bells and whistles if that’s what you need.

1 Like

Shotcut does not provide screen capture.

1 Like

Q1) What are the purposes of functions below (I cannot figure it out):
= File > Open Other > Video Input = screen-capture-recorder > [OK].
= File > Open Other > Video Input = HD-Webcam > [OK].

Q2) Both above show error: Fail to open dsShow …
How do I solve them ?

Thank you very much :sweat_smile: !

While I can’t answer your question directly, it sounds you could really benefit from using a program like ShareX (as @Elusien pointed out) for a simple screen recording. More advanced screen recording, especially with a webcam, a program like OBS (Open Broadcaster Software might be more useful.

1 Like

This comes from
It is software that attempts makes screen capture appear to be a video device in Windows.
I do not know why it does not work since his examples use the ffmpeg dshow, and that is what Shotcut uses as well (via the ffmpeg library).

That is what you get when you do not use software dedicated to the purpose. Shotcut is not intended for screen capture at this time, and you are employing a trick.

What physical device is this? It shows no model name. Is it real, or is this another trick?

I have two webcam-like devices with which I test this feature on Windows, and it works for me on those (Logitech C920 and 2018 MacBook Pro). If it does not work, and you are a developer, you can try to fix the code yourself and submit a pull request. If you are not a developer, you can use another software to capture. If you are power user, the camera is cheap, and you can show that it works in ffmpeg or ffplay at the command line, send the make and model and I may buy one to look into it. Otherwise, if the camera is not cheap, you can send one to me (loan or to keep).

1 Like

I am a C# developer, but I don’t know how to develope ShotCut, it seems a C++ program (linux).

On the website here there are SDK pages for Windows, Mac and Linux. Click on the links and check them out. :slight_smile:

1 Like

HD webcam works for you :sunglasses:, wow, then how do you stop it ?


1 Like

I don’t have button [Stop Capture] and [Reset], I am working on Windows 10.

I’ve done ffmpeg labs again…
it’s proved again that ffmpeg does not accepts non-ascii device name.

I think you need to start capture first.

Then the capture file dialogue appears. Then the stop capture button appears.

1 Like

See, there is none of any button such as [Capture File] or [Reset] :grinning:

After you select the device and hit okay you have to choose the export tab to be able to capture and save the file.

1 Like

After some labs and over night thinking, I’ve got something for this ‘trick’:
I found that ffmpeg does not accept any non-ascii parameter,
Fail to open dshow message above should be caused by non-ascii characters.

really helpful, Thank you very much :sparkling_heart: !

This topic was automatically closed after 90 days. New replies are no longer allowed.