Ridiculous export time and file size

Hi guys. I’m new to Shotcut, and I just can’t seem to find properly working export settings for my edit.
I have a 25 min video which I want to export for youtube. But even turning down the settings all the way still gives me ridiculous export times and file sizes.

For example:
Youtube Preset, then going to “Advanced” and tweaked the following things:

  1. Framerate = 30
  2. Bitrate = Average 2 Mbit (which is extremely low and not usable btw, but I tried it to see if it even helps)
    Resolution is 1080p (both for export settings and on my source files)

When I hit export, it takes a couple of minutes before it even gets to 1% done. At this point the file size is about 75MB. Which would mean that the whole video would result in 7,5 GB. For a 25 min video with 30 fps and 2 (!!!) Mbits. I remember when i recorded gameplay from the Nvidia Shield software directly, I got those kind of file size at 60 FPS and 20 Mbit.

Something seems very off here for me. Since when does a 2Mbit 1080p file take 100 megabytes per 15 seconds footage?

I tried various other settings but I always had to cancel it after 1-2%, because it took forever and the file sizes even at just 1-2% were already so big that I couldn’t believe it.

My system should also not be a problem. i7 6700K @4,6 Ghz (8 threads). 16 GB DDR-4 RAM, and a GTX 1080 (which doesn’t seem to be used for exporting as it has no load). CPU usage IS 100% on all cores while exporting, I don’t know what the hell it calculates there. I only got a simple video and audio fade in and two audio tracks (game sound and voice over).

What is wrong here?

Thank you!

What are your source file specifications?
What is your Video Mode set at? (Settings/Video Mode)

I never bother the advance settings with the YouTube preset. At times it takes a few minutes for me to get to 1% as well, then it just starts chugging along. For me it’s roughly about 1 to 1.3 minutes of export time for each minute of video. But the quality of the export from Shotcut is amazing, and I would just wait for it. I’ve got an i7-7700k, 32gb of ram, and multiple drives. Windows/Programs is an SSD, and I have a dedicated SSD just for recording/editing. If you have just one hard drive, and not an SSD things could really slow down for you.

Hi Hudson,

My source file is 1080p .mp4 files with 60fps and a total bitrate of 15 mbit. It has a total length of 40 min with 4,6gb size. But in my edit i only have half of it (25 min).

Video Mode is set to HD 1080p 60 fps. But does that affect export? I thought export settings are done in the export menu.

Please note that I am not just worried about the time it seems to take, but about the file size.

I just started another export based on the Youtube preset, but set FPS to 30 and bitrate to 8 mbit. So, I have half the length of original video, half its framerate, and half its bitrate. The resulting file should thus be maybe 30% of the original file, so 0.3*4,6=1,5gb. But still, even after 5 min of exporting (again, CPU has all cores maxed out at 4,6 ghz), the progress shows 1% and the current file size is already 400 MB !? Unless the progress indicator is broken, something is definately weird here.

PS: I got an SSD too. And 16 vs 32 gig probably make no difference, because my system peaks at 7/16 gig used while exporting so it seems Shotcut isn’t using that much anyway.

Thanks for trying to help me!

Then use Quality-based VBR (which is what the YouTube preset is set for).
I just publish a few video games I play on YouTube. I record in VBR, edit/export with VBR.

I just canceled my previously started export after 15 min when it had 7% progress and 1,5 gb file size, wtf is this program doing…

i am now trying again the original youtube preset as suggested by you, will keep you updated how it works…

Well, this program just doesn’t seem to work properly for me… I will let it finish just for the fun, I would like to see what ridiculous file size it will have in the end and what it contains… don’t know how it can even physically generate that much executable data for 25 min of video

simple math:
(25 min * 60 sec/min * 30 frames/sec) * (2 Mb/sec / 8 b/B) = 11250 MB ~= 11 GB

And that is just for the video bitstream, not including audio or container format overhead.

100% CPU usage is a good thing. Obviously, it means it is working as fast as it can. It is calculating a lot of things, and a big part of it is H.264 video compression, which is inherently intensive. You are probably used to GPU encoding, which hides video encoding from your CPU.

Well guys, it finished! Turns out indeed the progress indicator is just broken here… I don’t know what it is supposed to indicuate, but certainly not the overall progress in terms of required work time. he first 8-9% took 95% of the actual work - AND file size. But then - woosh - it finished the remaining 90% in a minute and the file size didn’t increase anymore either.

I ended up with a 970 MB video exported in 28 minutes. now THIS is what i expected.

@shotcut: Don’t know what exactly your calculation there is depicting, maybe uncompressed file size? But obviously 11 GB is not a normal file size for 25 minutes of 1080p @30fps and 2mbps. As you can see from my resulting file, it is 970 MB (with 60 fps actually, and surely more than 2mbps on average). Thanks anways for answering.

Sorry for bothering you guys, I just always cancelled it at some point after thinking that this will actually take 5 hours and create a 15 gb file. should i report some kind of bug for the broken progress indicator?

Sorry, my math was * 30 fps, which was incorrect.

(25 min * 60 sec/min) * (2 Mb/sec / 8 b/B) = 375 MB ideally

It cannot predict the future. It does not understand the first part of a project is complex but later is simple. It simply says the initial X% took Y seconds and extrapolates from there. If you do not like it, then ignore it. I am not going to try to improve it.

ah, so you are actually the dev of this? well first of all thanks for making such a tool for free then. I’m a dev too so I know there can be hard feelings when it comes to critizing what one has coded :wink: While I think it should be possible to make the indicator “smarter” (after all, you do have all the information about the sources and the edits in the program), I guess it could be pretty hard to make it predictable - and it will increase the overall time additionally just because of the beforehand calculations. Maybe you can just add a little mouse-over popup or something explaining that the estimated remaining time might be subject to drastic changes. I almost uninstalled the program because I thought it produces shitty output. But as it doesn’t, thanks again! :slight_smile:

This was for a 5 minute video I made on Monday.
I don’t think the indicator is broken at all.

I will make the progress indicator ignore the first 1% since 0->1 includes the overhead of startup, which can be significant for large or complex projects.


Well, I think it is :wink: It if tells me it will take 4,5 hours (and keeps telling me that for 95% of the entire time it took), and then takes just 30 min suddenly in the end, it is broken. Obivously it might depend on the project how reliable it is. I’m not sure what caused the extreme off-value in my case, as I have a very simple project. Just a video with a 1 second fade-in, two audio sequences without much editing, and a plain static .png file in the end as an overlay over the video (for about 15 sec). The middle 90% of my sequence are just one video track without edits, and two audio tracks without edits. So it doesn’t really make sense that it is that much off for so long, as no changes in processing requirements should be present within the majority of the sequence. But whatever, the dev already made it quite clear that he doesn’t wanna improve it, and I that’s fine for me, I was just thinking about people in future that might have this hazzle as well…

I don’t know why you experienced this either. But as you can clearly see, I do not experience what you are describing. I am running Shotcut version 18.11.13, with Windows 10 Home.

You can’t say it is not broken because it works for you. It doesn’t work in my case, so there is some code in the program that is incorrect. Doesn’t mean that this code will apply in all cases. It seems to be a bug, those tend to be appearing only under certain conditions, and might also not always be reproducable. Maybe as a programmer I have a different definition of “broken” than you have as a user. I don’t mean to say it is completly or always broken :slight_smile:

This topic was automatically closed after 90 days. New replies are no longer allowed.