Rich Text Scroll Up - Ends Too Early

What is your operating system?
Microsoft Windows 10 Home

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.03.21 (64-bit)

Can you repeat the problem? If so, what are the steps?
When creating scrolling text using the “Text: Rich” filter, in the rendered version of the file, the text leaves the screen too early (more significant for longer scrolls).

  • Open Other → Color
  • Set Preset to “transparent”
  • Click OK
  • Drag clip to Timeline
  • Drag clip length to 10 seconds
  • Add filter “Text: Rick”
  • Paste some text into the text field
  • Set Overflow to “Visible”
  • Set Preset to “Scroll Up”
  • Scroll timeline to see that text enters screen at 00:00 and leaves exactly at 00:10
  • Export File as YouTube Preset
  • Observe in mp4 output that text leaves screen at 00:06 (too early!)

Exported video screenshot:

Not a bug, it’s how the preset is designed to work.
At 00:00 no text is visible.
At 09:59 no text is visible. (10s at 60fps)

Scroll up

scroll up early
scroll up early.mlt (13.2 KB)

Might want to try out “Slide In From Bottom” instead, and adjust the last Keyfame to here.

slide in from bottom
slide in from bottom.mlt (11.9 KB)

1 Like

Hi @glederfein
I don’t know if this will help, but for long text (longer than the screen) I always adjust the background size before applying the Scroll preset.

Just transfer the vertical size shown on the Text size line to the vertical Background size.
I usually round up the number, but you don’t need to.
Then apply the Scroll Up preset.


1 Like

Sorry, both these tips don’t seem to help.

  • Setting the Background size to the Text size before applying “Scroll Up” made no difference - text still ends too early.
  • “Slide In From Bottom” isn’t the effect I’m looking for - I want the text to leave the screen at the end
  • I tried rendering the “scroll up early.mlt” - If I don’t touch anything and render right away, it renders right, but if I just click on the video track and render, the text ends early. Anyways, I can’t reproduce with my own project. Hudson555x - was this project created in the Windows version of Shotcut?

Windows 10 Home

I can’t reproduce your issue.

Could you make a new project with just the minimal amount of steps and upload the MLT here?

Sure, here’s a sample project.
You should be able to see that in the preview the text ends at the end of the video (00:10). However, after rendering, the text ends around 00:06.
text_scroll.mlt (5.6 KB)

I see what you’re talking about now. You have text that is not visible in the bounding text box of the filter. Possibly a fault with the bounding box. Perfect MLT uploaded to show the exact problem. I was able to duplicate the issue.

The real fix is what @MusicalBox has mentioned about setting background size to match the text size. Background has to be larger than the text size.

scroll fix

scroll fix.mlt (7.6 KB)

For some reason, I can’t edit your MLT to get it’s proper size.
But this is what you would need to change to make it work correctly.

Ok, figured out how to edit Rich Text which already has a preset applied to it.
Select (defaults) from the preset menu.

I was able to fix your original mlt uploaded.
text_scroll-Fixed.mlt (5.6 KB)


This is the reason why Text Size is displayed. This needs better documentation of course. There are use cases where you do not want to make the background as large as the text such as a non-transparent color box. Then there is the overflow parameter as well that affects things.

So I tried opening your fixed project.
When I click on the filter it shows me a larger text size than your screenshot (4872).
So I:

  • Changed Preset to “(defaults)”
  • Updated Background size height to 4875
  • Returned Preset to “Scroll Up”
  • Tried rendering again

Still getting the same issue…

My guess is that for some reason the text font is changing when I open the project?

Attached below my filter settings and project file:
text_scroll-Fixed2.mlt (5.6 KB)

Unfortunately I can’t duplicate the issue. I’ve opened up the MLT I posted several times with no difference, even adding tracks.