Rich Text not appearing after render


Just encounter a new problem … rich text filter not appearing when export to either youtube (.mp4) or .mov formats. It is strange as I am pretty sure Rich Text works before on this same version of Shotcut 20.09.13. Tried a few times … still not appearing on exported formats.

Here’s the result of youtube (.mp4) …

Smoke dancer … rich text not appearing

The setup in Shotcut screen shot …
The video of “dancer in smoke” are in .mov format

Your version (which is not latest BTW) has a bug in Rich Text when you enable parallel processing in Export. Either turn it off or upgrade.

Hi @Leader

I upgraded to Shotcut 20.09.27.
Also check that the “parallel processing” is disabled.
The result still can’t display the “rich text” ??

Sorry, then I do not know what is wrong. Are you adding additional filters after Text: Rich? I quickly mocked up your situation but did not reproduce it. Does it work if you remove the two transparent clips and simply use one on the clip on V2? If you make a new project and make the simplest possible test of rich text, does it work?
You can upload your project file, and I will take a look into it.

Smokedancing.mlt (32.3 KB)

Try hiding one of the V2 track and export … same results. Very strange as this is quite standard way of doing with Simple text too.
Here’s my MLT files and 2 mov files.

Appears I can’t load the mov file even if I rename it with .txt

I reproduce it with your project file, but I have not figured out exactly how it got that way. It works if I recreate the rich text filters. Somehow yours are defined with no text color (in the HTML inside the project file). If you put the cursor in the middle of your text, and click the text color button in the rich text editor toolbar, it shows “HTML: #000000”, which is black. This results in black on black. The rich text editor is not showing it as black because your Shotcut theme is dark. In the absence of a color definition, it is using the UI theme’s text color. Therefore, to fix this, you need to visit each rich text filter, select all the text, and change the color to white. While you are doing so, I suggest to also change the font to something other than ‘MS Shell Dlg 2’.
Did you use paste to put your text into there? Did you use copy and paste to produce all of the other rich text clips after the first one?

Hi @Leader,

Your approach solved this problem indeed :slight_smile:
Thank you so much for spending time on checking this … I won’t have solve this problem by myself.

I don’t recall copy/paste text into the rich text filter … however, after creating the first one, I simply copy it to the rest of clip where text is needed. So the culprit is the first one I created …

As for changing font, I have no clue how to change font in rich text. Appears not available option for this.

Sigh - use the tooltips on the editor toolbar

This topic was automatically closed after 90 days. New replies are no longer allowed.