Reverb filter applied on track stops when the clip ends

What is your operating system?
Arch Linux

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
ARCH-22.04.25 64-bit

Can you repeat the problem? If so, what are the steps?

I am trying to stop an audio clip with a reverb effect. I cut the last part of my audio clip and put it on a separate audio track (A2) and added the Reverb filter on track A2.

It turns out that the reverb effect ends as soon as the clip ends. This is the same as applying the filter on the clip itself.

ksnip_20220603-215624

I don’t think this is the expected behavior. The reverb effect should continue after the clip ends when applied to an audio track.

My current workaround is to extend the audio file in Audacity by inserting a few seconds of silence at the end of the clip.

Not a bug. There is no more audio on A2 at the end of the clip, so there is nothing to apply
reverb to. If you want reverb applied to everything you need to add it to “Output.”

Update: Oh wait, now I understand. Because this has a delay effect you expect to hear a decay beyond the end of the clip. Unfortunately, this is a limitation in the engine, which is difficult and unlikely to be fixed.

Yes, that’s what I meant. Thanks for the explanation. What a pity.

You could import your audio file into an audio editor like Audacity and add som extra seconds of blank audio to the end, and export it, when you add it in shortcut with reverb on the end you will hear the reverb tails over ther periode of the blank audio.

2 Likes

It’s also possible to do this directly in Shotcut.

EDITED VERSION

  1. Select and Copy the audio clip that needs a silence at the end.
  2. Launch a 2nd Shotcut window.
  3. Add an Audio track to the Timeline
  4. Click the Paste button in the timeline Toolbar to paste the audio clip from your other project.
  5. Add a blank clip (Open Other > Color) just after the audio clip on the audio track.
  6. Adjust the length as desired.
  7. Export as a MP3
  8. Use the new MP3 file where you need it.

Video showing steps 5 to 7:

2 Likes

I’ve used a similar method, but used the clip itself for padding rather than a transparent clip:

  1. The picture below shows my project start point… An audio clip on a track, and the audio ends abruptly at the end of the clip. It has a Reverb filter applied with default settings. The lack of a silent tail in the audio clip leaves no room for the Reverb filter to work, and instantly kills the decay.

  1. Go to the audio clip’s Properties panel and manually change the Duration to be around 10 seconds longer. Shotcut will pad silence to the end of the clip to fill the new duration.

  2. Grab the right-edge handle of the audio clip and extend it out to the new duration. Note the silence in the waveform that follows the original audio. The Reverb filter has access to this silence and can continue its decay.

4 Likes

Clever. Very clever @Austin :open_mouth:
I’m in shock :slight_smile:
@Brian spent time trying to explain this thing to me when we were testing the Time Remap filter…
I should have remembered it lol

Thanks for the reminder and for coming up with a better suggestion :+1:
Hope you don’t mind if this inspires me to create a new Quick Tip video on my channel :slight_smile:

1 Like

Go for it! Everything I write here is in the hope of inspiring people to make cool stuff with it.

1 Like