Rendering speed and install method (repos

Hello,

Today I have noticed a performance issue with Kdenlive and I have found out that it applies also to Shotcut for me (and maybe it is related to MLT).

I’m using Fedora 39.

If I install the video editors with Flatpak they won’t use my full CPU (<20%).

Instead if I install them from Fedora’s repositories they will use the full CPU (>80%).

Render time of my last project was 5 times bigger because of this: 1 hour and 40 minutes vs 22 minutes.

Tell me if you have any guess of why this is happening or if you think that I should report this elsewhere (I have already reported it also to Kdenlive bugs tracker).

Flatpak does not use the same app settings as a package, AppImage, or portable. Therefore, check if Export > Advanced > Video > Parallel processing is enabled in each.

1 Like

Is it only the export time difference? Or does the application also have performance difference.

Maybe there is a difference in the usage of p-cores.

See here:

I don’t think it is the issue, but I have tested it.

I have enabled parallel processing for both and tested using my source video and just exporting without any editing.

You can see CPU usage at the bottom right, export time in the usual spot.

Shotcut from Fedora’s repositories: CPU 86%, 27 minutes (estimated) export time.

Shotcut Flatpak: CPU 26%, 1 hour and 16 minutes (estimated) export time.

Thanks for the reply.

I have a Ryzen 5 5600, I don’t have E cores.

Are you using hardware encoder on the Fedora package?

How do I check if I’m using it?

It is a checkbox in your last screenshot! It is turned off for the Flatpak.

Nope I’m not using it with the Fedora package.

PS: The two installations are at default settings, as said I don’t use Shotcut as my main editor right now, I have just seen that it has the same bug as Kdenlive.

I hope that someone could test this and report if they have the same issue… it really takes 1 minute of test if you have both the versions installed.

I do not reproduce it on my Pop!_OS system between Flatpak and my custom compile for my development setup. I do not use Fedora. It is possible Fedora has enabled some special optimization flags for compiling the x264 library. I doubt many people here are running Fedora and reading this bug report.

Ok, thank you!

Here is a screenshot of my Activity Monitor while exporting in Flatpak similar to yours (parallel process, no hardware encoder):

While exporting this moderately complex project:

Speed depends on track blending and filters being applied (more = slower). As you can see, it did OK considering.

A single track, 4K60 video looks like this in Flatpak on my system:

TL;DR: Ok, for Shotcut it was a setting within Flatpak, thanks for your time.

I have asked ChatGPT how to reset Flatpak settings:

  • I have used flatpak repair with no success;
  • I have deleted ~/.local/share/flatpak and ~/.var/app, now Flatpak’s Shotcut uses the full CPU while Flatpak’s Kdenlive is still “bugged” for some reason.

I don’t know the culprit, if it happens again I will investigate further.

Thanks for your time, I’ll close the issue!

PS: I thought I could close the issue but I don’t find any button.

1 Like

This topic was automatically closed after 89 days. New replies are no longer allowed.