Remove old shotcut snap from linux

Hi there,

New to shotcut and in depth usage of linux stretch. Tried to remove shotcut version 17 to install 20 but no success. Installed 17 with snap as per these instructions: https://snapcraft.io/install/shotcut/debian#:~:text=Shotcut%20is%20a%20free%2C%20open,and%20resolution%20support%20to%204k.
but even purge remove keeps listing version 17 when I search packages from repository in Aptus. every time i try to install again i get version 17 again. Anybody can guide me?

Thanks

These are not valid version numbers for Shotcut. Maybe you referring to the major version, which for Shotcut is based on the year.

Installed 17 with snap

To remove is as simple as sudo snap remove shotcut

when I search packages from repository in Aptus

I do not know Aptus, but it sounds like an unnecessary layer on apt, and apt is not snap. Extra layers can add bugs, and you should use the right tool for the job. I think you should use snap to manage snaps instead of some other tool. snap list shotcut tells you what you have, and sudo snap install --classic shotcut installs the latest.

P.S. also look in Shotcut’s About dialog to get the version.

Hi,
Thanks for helping. APTus is the package installer tfor popular pakages hat comes with Sparky Linux Stretch, in that aplication “shotcut” is not available, the downloaded shotcuts AppImage if clicked on, directly sends me to a CD burner, which this computer doesn’t have.
So I found that snap page and followed those instructions and got version 17.06… etc. which I called 17 in my previous mail.
Anyway, after the instructions on the snap page you type "shotcut " in the terminal and it says bash: shotcut; command not found, as it did when I first installed version 17xxxx earlier, I then tried apt-get install shotcut and it installed what snap had prepared, I say prepared because after doing what they mentioned there I could install shotcut and out came version 17xxxx when loaded, again. Removed everything including snap as you suggested.

I then logged in as root and did a search for “shotcut*” from the top level directory, hidden files included, got a lot of files and also the version 20xxxxx now in my download folder. I deleted all files except the downloaded version 20, emptied the trahcan.
Rebooted.
Followed the instruction on the snap page again and yes, saw version 20xxxx was prepared IF I followed your instruction, instead of “shotcut --classic” I used “–classic shotcut”
I got notice that version 20.09.27 was installed, gave command shotcut, got back
bash: shotcut: command not found
Tried sudo apt-get install --classic shotcut, didn’t work
Tried sudo apt-get shotcut 20.09.27, didn’t work
Tried sudo apt-get shotcut, and got version 17.06xxx again!

Going crazy!

Sorry, and thanks
Henk

From your screenshot you are mixing snap commands and options with apt-get, and that will not work. Do not use apt-get to install or manage snaps. If you did install the snap successfully at some point - as you seem to have per your description - but get “shotcut: command not found” then simply the snaps are not in your PATH environment variable. They do not need to be, and you can simply run the snap directly if you know where it went. On Ubuntu that is in /snap/bin so you can ls /snap/bin to verify that, and run /snap/bin/shotcut to launch it. I suspect Debian and most Debian-based systems are the same in this regard.

OK, that worked, version 20.09.27 opened. Thanks a lot for your help!

B rgds,
Henk

1 Like