Red Text renders Duller and more Blurred than Imported Video

Hello all,

I was wondering if someone could help with a problem I am experiencing with the vividness and sharpness of red text [from an imported video file] in my exported project.

I have a high quality FLV recording which I made of my PowerPoint presentation using OBS, which looks good both when I play it in VLC and when I import it into Shotcut (i.e., prior to exporting), but once I export it always* renders both reds [and other reddish colours like purples, though to a lesser extent] markedly duller and more blurred [PICs 1 & 2].

I need to import it into Shotcut to edit it and splice it together with other videos.

I observed no further degradation when I uploaded the project to YouTube as test, so I assume the compression must be occurring in my encoding in Shotcut, unless there is some automatic compression happening when I import into Shotcut which is for some reason not showing up in the preview window.

  • i.e., after various tests, some of which improved but didn’t solve the problem

Using “libx264rgb”: A Specific solution I found and tested, with mixed results [PIC 3]

This solution fixed my red text problem entirely, but made the dark colours too strong (i.e., the shadows are burnt out) leading to transparent images being lost (e.g., the alpha and omega symbols).

Shotcut also said that Youtube “will not handle [libx264rgb]”, and as YouTube is the destination for this project, this solution is, I guess, a dead-end.

Other testing I have done in Shotcut (on the basis of various threads I viewed):

  • Video: Both H.264 High Profile (Stock) and H.264 (Lossless, gives better results)
  • Video: Both Hardware Encoder On and Off (Off seems to give better results)
  • Video: Parallel Processing On and Off (On seems to give better results)
  • Codec: Quality-Based VBR and Constrained VBR, at 70, 97 and 100% Quality (imperceptible differences)
  • Codec: Fixed and Unfixed GOP frames (imperceptible difference)
  • Frames per second (FPS) from 60 to 30 (imperceptible difference)

Computer Specs
Processor: Intel(R) Core™ i7-9750H CPU @ 2.60GHz 2.60 GHz
Installed RAM: 16.0 GB (15.8 GB usable)
System type: 64-bit operating system, x64-based processor
GPUs: (Power Saving): Intel(R) UHD Graphics 630
(High Performance): NVIDIA GeForce GTX 1650 with Max Design -Q

Settings I have not tested in Shotcut:

  • Other Advanced “Video” Settings
  • Other Advanced “Codec” Settings
  • Other Settings

Testing I have done in OBS (if it helps):

  • Recording with both my Intel and Nvidia graphics cards (imperceptible difference in colour quality, currently using Nvidia)
  • Fixed frame rate vs variable (imperceptible difference)
  • CQP rate control vs. lossless vs. CBR (imperceptible difference)
  • Turning “Look-ahead” and “Psycho Visual Tuning” on and off (imperceptible difference)

“Christian tradition from the outset is not only saturated with Persian and Jewish ideas about the beginning and end of time, but is filled with intimations of a kind of enantiodromian reversal of dominants.” - Carl Jung, Aion 1951 [for those curious or concerned]

Usually the problem is due to chroma sub-sampling of YUV video, but it sounds like you could also have a color range problem or change affecting it. Please show the video properties of your input FLV file.

Thank-you for the fast reply, hope these are the details you need.

Did Shotcut ever prompt you to “Convert to Edit-Friendly” for any of the FLV files from OBS? Trying to isolate if the problem might be interpreting the originals, or something wrong with conversion if it happened.

Not for the FLVs, but I used to import MP4s with a different colour format, and I did get asked to convert for those (which converted to a comically large file with distorted shadows, making blacks greys and so forth, hence why I made the below change).

  1. I originally formatted in RGB color format and sRGB color space in OBS
  2. I changed OBS color format to I444 and color space to 709, and file format to FLV

You are using full range, non-subsampled chroma (4:4:4) for input. The default for most exports Shotcut is sub-sampled chroma (4:2:0 or 4:2:2) and limited range because that is most common in video. You can make it do full chroma and full range output, but some codecs do not support full chroma. Start with the FFV1 preset and in the Other text box, change pix_fmt=yuv422p to pix_fmt=yuv444p but also add in


You have to go to RGB because the engine does not support full chroma YUV; RGB avoids that.
Note, however, that YouTube will sub-sample the chroma. I do not know what it does with full range.

Thank you again, I really appreciate the help.

Unfortunately, the results after applying those settings are as with libx264rgb (i.e., it solves the red problem, but erases the transparent Alpha and Omega symbols with excessive darkness), and creates two additional problems:

  • The resultant video is very choppy (i.e., the animation lags massively) from the original file and how it plays back in Shotcut
  • It creates a 2gb file from the 48 second input video. The full project is 1 hour, so this size will likely be a problem.

I tried creating a different input file, i.e., an OBS file with:

  • I420 Color Format
  • Partial Color Range

Neither were particularly successful post-rendering.

I may be stuck with the options I have, meaning I might need to alter the PowerPoint itself.

Kind regards,


This topic was automatically closed after 90 days. New replies are no longer allowed.