Rattling audio after export

I have video taken on smartphone, rather good.
When I create a clip out of it, I need to keep original audio which is important.
Audio quality is good when I listen to it in the shotcut (either playback of original video or clip preview). However, once I export my project, audio becomes seriously rattling on basses, like speaker is broken, if you understand what I mean.
I tried everything. From some moment I’ve just created a 10 second project with a small piece of source and did endless experiments with it, as export takes just a few seconds.
I tried different export audio formats, tried to set very high fixed rates for audio, applied different audio filters - result is nearly same, rattling remains.

Original clip is mp4 and audio properties are following:
AAC, 48000, format fltp.
Either I am missing something obvious or … ??
Any suggestions?

1 Like

Have you looked at it with the “Audio” view layout?

It sound from your description that the bass frequencies are so loud that they are clipping, exceeding the maximum that the Export setting can encode.
That will make the bass “rattle”.

Try to export as WAV to get a more clear view. Sometimes the AAC codec does not perform well.

1 Like


Please try something, apply an audio level filter of -1dB and export a 10 sec clip again.
Check if it’s better or the same.

AAC, MP3 or any other lossy codec, changes the level (ever so slightly) which sometimes leads to clipping and hence audible distortion.

By giving an extra 1dB headroom, you may just create enough “breathing” space for the peaks not to clip.

If the exported file is brought back into Shotcut and played in the Source preview, is the audio still bad? I wonder if the volume of your media player is higher than 100%. VLC lets users do that.

1 Like

Thanks to all who replied, I really appreciate quick help.
I think it is combination of advices given.

First, it is really a player as suspected by @Austin, it was at 150%. When I put it to 100, rattling is almost gone.

Second, when I look at audio in shotcut, many peaks are in fact near the top, so I guess it shall also help to reduce them as suggested by @Paul2. Which audio filter shall I use for that?

@shotcut I get an error if I select wavpack audio codec, so unfortunately not able to try that.

1 Like


If the too-loud peaks are only in a few places, you have the option of using Keyframes on Gain/Volume to only lower the dB at those times.

Another option you can also try:
Observe whether the audio peaks always correspond to the low frequencies (with the audio spectrum viewer (Shotcut-audio layout).
Then, if so, you can use the bass and treble filter. This filter has 3 frequency cuts (100 Hz - 1kHz - 10 kHz) and a good setting can make that -1 dB difference in the low frequencies.

This filter has no keyframe adjustment so the adjustment would affect the whole clip.
This filter has the advantage that you would lower the volume (you can also increase it) in one frequency range, while the other frequencies would remain unchanged.

You have options.

If you want to maintain the overall tonal qualities of the sound track, then the
Gain/Volume filter as suggested by @kagsundaram is the way to go.

However, if you don’t mind changing the tonal qualities, then as @ejmillan suggested,
you can try and find out what is the frequency range of the sounds that are causing those peaks and reducing them a dB or two at a time.
It will most probably be the bass/drums, around 40 - 150 Hz.
Of course, that is only a guess.

Ideally what you should be doing, is using a compressor or limiter.
Ever so lightly, just keep in mind that a compressor and a limiter or two different animals.
Each case is different and calls for different “tools”.

Just remember that different attack and release times on a compressor will affect the
Golden rule, easy does it.

This topic was automatically closed after 90 days. New replies are no longer allowed.