Proxy and preview scaling not working after change speed to 6x

Using win 64bit 20.09.13 shotcut.
When the clip is set to 6x speed, the preview scaling and proxy seems to be disabled in that clip. Previewing in that period become laggy for my computer. The rest of the projects are fine. The problem can be solved by restart the shotcut.

I am not able to reproduce this. “laggy” is not evidence that it is working or not.
You can look in Properties for the selected clip to see if the Codec or Resolution are changed to reflect proxy in use. In the below, the resolution is less than clip source per my preview scaling and says “(PROXY)”:
image

I also checked the XML written by Export with Use Preview Scaling turned on to confirm the proxy is being used, and it is.

Thanks for quick reply.
I spent some time to replicate the problem. Clips longer than certain period (my clip is ~4min30sec, not sure about the threshold) will automatically change back to original resolution. In my case, I set preview scaling to 360p, shown in property window is 360p(proxy). When I change the speed (no matter from / to what number), the clip jump back to 1080p(proxy).
using win7 64bit.

Weird as duration should not make a difference. I just tested on a file that is a little over an hour long, and it worked for me. Maybe you should start with an empty project, reproduce it, and provide here the exact steps.

Can’t reproduce the problem with a new project, but the old one still has the same problem.
Not sure about the exact step triggering the error. I’ll feedback if I reproduce it. Thanks.