Proxies are not working for old projects for some reason

Hello everyone,

I’m not sure how to recreate the problem I’m having… I’m working with some 4k clips and normally I would use proxy clips and preview scaling at 360p so they are easier to work with in Shotcut. I have Shotcut mlt files that I used with proxies and they worked great, but now that I want to continue editing, for some reason the proxy for the projects that worked previously are no longer working. When I open these projects the performance is as if I have Proxy turned off. When I go to Settings > Proxy, the proxy toggle is checked. When I toggle proxy off then on, I see a dialogue box that asks me if I want to create missing proxies and I click yes, but nothing afterwards. I tried to deleted the proxy files themselves in hopes that it would force Shotcut to recreate the proxies, but instead of recreating them, Shotcut now just gives the warning that the proxy file is missing and I need to find it. I restarted by PC and reinstalled Shotcut to see if that helps but no dice. I might need to reinstall and

Shotcut version 21.05.18

Windows 10 1909

I don’t know if this will help.
When the clip is selected, the information shows that it is a proxy (HEVC and appropriate resolution)?
In the Info tab, there is a button for proxy management per video clip (not the same as disable-enable in preferences all proxies). Have you tried these options?
I recorded a short video with the location of these options.

Unfortunately, when I go to the properties of the clips I see the full 4k resolution. it doesn’t say (PROXY) like yours… I click on the button that that says “Proxy” and the “Disable Proxy” checkbox is unchecked

I opened a really old project and toggled the “Use Proxy” option in the settings menu. Shotcut actually started making the proxies, but they are not applied for some reason… The “Disable Proxy” checkbox is also unchecked…

I am not an expert on this but I will venture to see possibilities.
In my case, I set the location of the proxies in the project folder (which is on a drive other than C:/).
For proxies that are created when there is no project created, I added a generic location (which I called orphaned proxies), so I can always delete those files because they are not associated to any project.
Maybe this is related to W10 security features that prevent writing to some folders.
It’s just a hypothesis and I don’t know if this applies to you.
Yesterday something similar happened with Proxy, but I was able to redo proxy and it worked fine. However I’m using release candidate 21.06.15 on Linux, so it’s not the same situation.

Can you access the location of the generated proxies? Do they play well with an external player such as VLC?

There is a way to reset the proxy that you can try. If it doesn’t work just click the left arrow (in the toolbar at the top of Shotcut) to undo the operation.

Note: I have never used this function in a project so I don’t know if it affects the export. :eye:

I’ll give your suggestions a shot

Ao I need to clarify a couple things because some of the confusion is user error on my part: For the really old project that actually created proxies after I toggled the “Use proxy” option, it isn’t an issue anymore because all I had to do was reopen the project for the proxies to apply.

The real issue is that when I toggle the “use proxy” option for a more recent project, the Make Proxy job doesn’t run at all. My thoughts are that if I turn on proxy and the proxy job doesn’t run, then it probably means that the proxy files are already created so there’s no need for Shotcut to make proxies that are already there. So, I went to check the proxy folder that I use for all my projects, but it isn’t there. So, if the proxy files are not there and Shotcut still doesn’t want to make them, then it probably means that Shotcut somehow thinks that the files are there but in reality, are not.

I remember the Proxy button you sent me to and I clicked on in and clicked on the “Copy Hash Code” option. So now I can see the hash for the proxy file, I noticed the hash code is basically used to name the proxy files.


So this basically confirms that Shotcut is holding on to a hash/proxy that doesn’t really exist. Now I’m searching my entire computer to see if anything matches the hash, because there might be a forgotten folder somewhere with proxies. But how do I “clean” out the hash from the project folder in the first place? I think I’m getting really close to solving this issue.

PS: I tried the reset option as you suggested. It reset the clip to it’s original on modified state on the timeline, but proxies still doesn’t work

I’m now with a Linux project so I don’t remember if these options are like this in W10, so a couple of ideas for you to explore:
-Locating the storage location in preferences

-Locate the location of a clip’s proxy file

As I said before, I am on Linux and it is a known problem that in cases, from the menu there is no access to the folders (so in my tests I don’t access the storage folder and that’s why it doesn’t appear in my videos). However this doesn’t worry me because I always configure the location and I know where to find those files.

About the hash, I didn’t comment on that, because I don’t know what to do with it. First I would have to search the forum for matching words, read and read (after translation) and draw conclusions.

I followed your steps but sadly the proxy file doesn’t exist anywhere on my computer. This means that Shotcut believes that there is a proxy file when in reality there isn’t really a file. I’ll need to find a way to “delete” the proxy information from the shotcut project

I found this:

Aright! So I was able to get it to start creating proxies, but I had to install an older version of shotcut. I installed Shotcut 21.02.27 and then opened the project that wouldn’t create proxies. At that point a dialgue window came up asking to repair the project and I clicked yes.

and then toggled the “Use Proxies” setting and then it started making the proxies! Thanks!

1 Like

You got it. Now we can go have the beer, after sweating so much, hahaha. :laughing:

This topic was automatically closed after 90 days. New replies are no longer allowed.