Properties Box not being displayed in the editing tab

I apologize in advance if this question is a result of my lack of knowledge, but I am not able to view the properties of a clip when I am working in the “Editing” tab. This includes right clicking on the clip and selecting properties, selecting properties from the top menu bar or clicking the Properties tab. However, if I switch to Logging or FX, the properties dialogue appears.

Is this normal behavior? I’d like to have quick access to properties to change the speed of a clip during editing. I’m using Linux (Ubuntu 20.04). I can provide a screenshot if needed. I’d note as well that I also use the Windows version (both the latest), and this issue does not occur in the Windows version. In addition, in the Linux version there is no start and stop buttons under the viewing screen (not a big deal because I can use the keyboard). Just mainly wanted to know if this was normal.

Many thanks for any replies


I noticed that happen once before.

In my case, I was quite alarmed until I realized I had done it to myself, by accident.

Ctrl2 will toggle that tab on and off, as will the “Properties” item in the View menu.

Thank you for your reply. In the view I was using, none of that worked in the “Edit Tab”. However, I posted prematurely because I discovered I was not in the default layout. When I restored the default layout, it went back to what I was expecting. However, there still are no start and stop buttons under the viewing window, but as I mentioned that is really not important as the keyboard shortcuts work fine.

Thanks for your help


Curious. I could not replicate that. I tried.

Manipulating the size of the View window, hiding/revealing control icons.

I never experienced this in 9 years. Click Properties on the main toolbar and send a screenshot.

in the Linux version there is no start and stop buttons under the viewing screen

That is a very bad sign too. Where did you get and how did you install Shotcut? You can send the first 5 lines of View > Application Log if you are unsure.


Sorry for the delay in replying, different time zone. I have just checked again and there definitely is missing play, rewind and stop buttons missing from the Linux version. I installed directly from Ubuntu’s software respository. The log shows this:

[Info ] Application::Application Starting Shotcut version 21.01.29
[Info ] Application::Application Linux version
[Info ] Application::Application number of logical cores = 4
[Info ] Application::Application locale = QLocale(English, Latin, United Kingdom)
[Info ] Application::Application install dir = “/snap/shotcut/186/”

I have also tried to attach a screenshot of both Windows and Linux, both the same version.
Should I uninstall and reinstall?

Thanks for your help.


I just wanted to add that the properties box is working as normal now that I have reverted to the default layout.


1 Like

@sprocket - When I said I couldn’t replicate it, I meant that I could not get the Play button to disappear, although I could get the FastForward And GoToEnd icons to disappear, along with others. The video I made shows how the icons vanish when the horizontal space (which is user adjustable) for the view window is small.

I am running Ubuntu Linux 18.04 (Kubuntu f;avor).
I ran the test shown in the video both on Shotcut 21.01.29 and 21.02.15beta.

Manipulating the size of the View window, hiding/revealing control icons.

My apologies. It was purely my lack of knowledge and premature posting. I have found exactly what you describe and it is working beautifully. I completely new to video editing and still discovering. To make it worse, I am learning Shotcut along side Cinelerra. Shotcut appears to have a much smaller learning curve and I am thoroughly enjoying it.

I am curious as to hardware differences. I mentioned earlier that I have both the Linux and Windows versions in operation. The Windows version runs on an HP laptop with an A10-9600P with 16GB RAM. The Linux version runs on a ten year old Dell laptop with a second generation i5 and only 8GB RAM. Maybe its just the differences in operating systems, but the Linux version runs circles around the Windows version, even with better hardware. Very rapid read/write and loading, where the Windows version is sluggish and choppy.

Many thanks for your help. I’ll more research before I post an issue again.


1 Like

It is how we learn.

The learning curve from not-a-video-editor to Video Editor is steep, no matter what the tool.

You will find a wealth of information here on this forum, and on this Help/HowTo channel, also a fine crew of patient teachers, both volunteer and staff.

Thank you for your encouraging words. I have found only one comprehensive course (the one from James Woo.) I am about to buy that and get going with it. I have some beautiful footage from my drone but until now hadn’t ventured into doing something with it.

Thanks again.


1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.