Projects missing after update?


#1

Hi,

I recently updated to Shotcut 19.01.27. When I went back to continue editing a project, all my previous project files weren’t present.

Is there a known issue where project files are being removed after an update? I’ve tried searching my entire PC by the name of my project and am just getting dead shortcuts returned in my AppData.

Many thanks!


#2

This is nearly impossible unless you are using Windows installer and storing your projects in the program folder (e.g. C:\Programs Files\Shotcut), which you should not do! Where are you storing your projects? By default, they go into your Videos or Documents folder. I have never seen anything like this in 7 years working on Shotcut. Outside the installer, Shotcut does not manage your files except to open and save them upon your direction.


#3

Thanks for your reply! I was storing the projects in a different location to the Program Files (D:\Shotcut\vid). All that’s there now is a corrupt export I cancelled as a test (definitely saved the project correctly before).

There’s nothing in the recent history in the application itself either. FWIW I did have the project open (already saved) when I ran the update, but I don’t see why that would cause any problems.


#4

Are you sure you are running Shotcut? Where did you get it? Show a screenshot of the About Shotcut screen open. I have no idea what happened. I suspect something is wrong on your system outside of Shotcut.


#5

shotcut%20snip


#6

What Shotcut version were you using before this one?
When you mean your “previous project files” are you talking about the mlt files?


#7

I just checked back and it turns out D/Shotcut WAS my install directory (I’d have assumed it would have been in program files). So my own stupid error :slight_smile:


#8

You might be able to get your projects back if you restore a previous version of D/Shotcut.


#9

Any idea what the best way to go about that would be? Apologies for the noob question!


#10

Select the folder. Right click. Use the restore previous versions function.

image

It’s also available when you view a folders properties.

image


#11

No previous versions available :frowning:

Ah well, only a couple of hours lost I guess. Thanks for helping