Problem with no captions after export for YouTube

Hi there,

Why shotcut video subtitles can’t be seen after exported to YouTube format?

Could someone please assist me?

Thanks and regards

I still can’t understand what you mean by

in the post.

Are you talking about the text filters not showing up correctly? Because there is no subtitle creation feature released till now.

For better understanding, can you post a screenshot of your shotcut window.

Yes, the filter text is showing at mlt file but after exported to mp4 format it doesn’t show up. Kindly see the screenshot attached.

Thanks for replying me.
mlt file & mp4 file.pdf (314.4 KB)

You are viewing 2 different locations.

You have a clip showing at 1 second, 10 frames

In VLC, you are showing at 3 seconds (which I have highlighted with a green box)
This could be 1 of 2 clips at the 3 second mark.

Click on both of the clips, and check your filters.

You are right but there’s totally no captions for the entire video. Fyi, I cut every scene and add filter rich text with black background but after exported the video to mp4 the captions wording disappeared and only left the black background.

Do you have problems exporting video text / captions/ subtitles?

Kindly let me know.

Regards and thanks

What version (number) of Shotcut are you using?
Can you select a clip that didn’t export properly, click on the filters panel, and share the screenshot of that panel?
Do you tracks above the 2 shown?

Can you check the filter again, actually on the screen where you put the text in, there is a font color option. Can you verify it’s set to White, or the color of your choosing?

If you pasted text (that was black in color) it would be set to black. There is a slight bug with the Text:Rich filter where it shows white, when the text is actually black in color. Setting the color one time, sets the true color of the text.

My problem has just been solved. You’re right, I didn’t change the font colour to white, it’s black. I have changed it to white colour and exported to mp4 and now all the captions can be seen already.

Thanks so much for your time and help.

Best regards

This topic was automatically closed after 90 days. New replies are no longer allowed.