Problem with masking (custom mask track)

I have a textanimation made in a 3d programm that i want to lay over the footage. footage is in track 2, textani in track 1. I put mask (advanced from file) on textanimation to just let the text. But the mask is only working on half of the screen (or maybe 2/3) on the left part. Is this a bug or do i missed something?

I created the alpha mask video also in 3d program and made it a mp4 video in shotcut in advance.
I have the textani and the mask of it in singe image sequences. Not sure how this works as a mask.
Is that possible in shotcut?

how can i add a screenshot here?

thank you

Why not export text animation with alpha channel from the animation program ?

In the Mask:From File settings, did you select File Custom, and enter mask video location ?

You are either inverted or not communicating clearly. footage should be on V1 and textani on V2.

But the mask is only working on half of the screen (or maybe 2/3) on the left part.

It will depend on the the Threshold parameter unless you turn that off.

how can i add a screenshot here?

Try harder. There is a button and drag-n-drop. Your screenshot should show the Mask: From File filter as well as the timeline tracks.

Thanks for your quick answers!
Maybe i was not clear: the textani is on top of the footage, textani is named V2. As i understand the top layer plays first and lets only through what is masked out. Where do i find the threshold parameter?
Here is the screen. I tried it with masking and also Chroma key:

As you can see, the textani is coming on top but the mask is only working on the left hand side.

thank you

If you have a separate file for the mask or alpha channel, you can use filter Mask: From File. It has the Threshold option. You can also choose whether to use the Brightness (luminance) or alpha channel of the file.

But as @pdr noted, if your animation program can output a video with alpha, it is much easier and cleaner.

The 3d program outputs single images and also the alpha mask as single images. I also can generate a psd-file with alpha, but that won’t help i guess. The problem is the mask seems to work only on the left side - is that because of threshold? I would assume threshold does something similar like fade in but not only cover the left side (see image). I guess there is still something wrong, isn’t it?

I also tried the mask from file and it has exactly the same result - only working on left half.

I also generated a video for the textani and for the mask as mp4 with shotcut. But that is a cumbersome way. Can i also apply image sequence for textani and same for alpha channel? Or is it only working as video in mp4 format for example? Still not sure what is wrong here.

Problem solved!
Must have been my problem, obviosly i left the default rectangular mask in the settings, although i am quite sure i set the mask from file option (custom defined).
Here is how it should look like:

Still the question: can i use image sequences for textani and alpha mask instead of video files?
That would make things even easier. But i dont see a simple way for that.

thank you all!

You can use an image sequence as a video clip: open the first image and click the checkbox in Properties. You can NOT use an image sequence for the Mask: From File mask source.

Thank you! I knew you can use an image sequence for the video, unfortunatly not for the mask itself. So i have to convert the image sequence for the mask first to a video and than use it as mask, which i did and now worked fine. I think a PNG can have transparency, maybe we can use that for the overlay including the mask? I think i could generate these PNG with my 3d application - that would help to make things easier :slight_smile: