Problem with crop filter

Hi. When I apply a crop filter, the 1st frame of the clip has the crop settings of the previous clip. This doesn’t apply to all the clips but more than the half of them. It doesn’t show that in Shotcut but only when I export the file. How can I fix this? Thanks

Which version of Shotcut?
Which OS?
Could your post your mlt (save project file) here? You can drag/drop the file in the reply window.

Are you changing the frame rate when you export? That might cause this.

I use the last version on Windows 7.
I’m not changing the frame rate.
eoe.mlt (246.0 KB)

Ok actually the original framerate was 23.976 and I exported it to 23.974. Is this enough to make it bug?

How/where did you make that frame rate change?

I didn’t, it was automatic.

OK, it is probably a bug due to the strange project frame rate that was gathered from the first clip you added to the project (and because Settings > Video Mode = Automatic). From your .mlt I see that it is 27187/1134. There is likely some rounding errors occurring since the project file saves edits with millisecond time values.

Ok so the answer is to export at 23.976 fps?

I reproduced the problem using the frame rate from your eoe.mlt. I also found the bug, and it was not exactly as I claimed above but something simpler that I will fix for next release. In the meantime, in the Export > Other tab, enter the following lines, which are the values that came from the <profile> in your eoe.mlt :


In future projects, you can avoid the problem by choosing a specific Video Mode in Settings menu instead of Automatic.

This has been fixed for the next release v18.09 due in about a week.

Thanks it worked

This topic was automatically closed after 90 days. New replies are no longer allowed.