Preview window not visible in 22.04

What is your operating system?
openSUSE Leap 15.3, GNOME/X11 environment.

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
22.04.25 (flatpak). It’s 64bit.

Can you repeat the problem? If so, what are the steps?
Open a previously saved .mlt file. The preview Window is not visible. Nothing happens when I click the “play” button or double-click on an item in the input list.
Same effect if I create a new project. Switching display method from openGL to Mesa didn’t change anything.

The problem didn’t occur with previous versions of the shotcut flatpak package (last tried roughly 1 month ago). The problem also doesn’t occur with the openSUSE native package for Leap 15.3 (21.03.21). I’m currently using the native package as a workaround, but I’d like to be able to use shotcut 22.

I do not reproduce it on Ubuntu 20.04. You can use 22.04.25 version by AppImage or portable from our download page. It would help a little to know if that build works for you.

I have the same issue here, also on openSUSE 15.3. Will check other options later.

The AppImage works, indeed. So it’s apparently a problem with the Flatpak, probably some sandboxing / permission issue. Any idea what to watch for?

@shotcut, when you said “I do not reproduce on Ubuntu 20.04”, did you mean the Flatpak or AppImage?

Flatpak. I test it briefly after I update it.

Thanks. So it looks like an issue between flatpak and the OS :frowning: I had hoped for something eaiser.

Please see the bug cross-posted to GitHub for followup.

SOLUTION: unset the environment variable SDL_AUDIODRIVER on openSUSE before running shotcut, or comment out the line setting it in /etc/profile.d/ See also openSUSE bug 1189778.

1 Like