Preview not using the dedicated screen estate / not anchored where is should be

Hi !

I believe the preview is not behaving properly.

  • It does not use the available screen estate of the preview pane
  • it should be anchored somewhere more sensible (top left corner of the preview pane ?)

Setup :

  • Shotcut-200412.glibc2.14-x86_64.AppImage
  • Kubuntu 20.04 (but all issues below were also met on 19.10)
  • Qt 5.12.8 // Plasma 5.18.4
  • Intel Core i7 7700k + 32GB RAM + NVidia GFX 1070 + SSD disk
  • 27" monitor with 3820*2160 resolution

How I use Shotcut:

  • I use Shotcut maximized on my screen (I see my Ubuntu system bar on the bottom of the screen) but issue it the same with the FullScreen option in Shotcut.
  • I work on a 2160p timeline 23.987fps.
  • I use Preview scaling to None (because it almost OK this way)
  • Playback is using Zoom fit for all below parts of the test case
  • Display settings use a 137.5% global scale

My shotcut screen setup is the following :

But the preview pane is never using the available screen !
The preview is anchored to the bottom of its pane, and never uses the screen estate it should !

It is also visible when I resize the Timeline pane

Maximed timeline

Minimized timeline

The playback of the project has the same smoothness (or lack thereof) whatever the size of the preview pane !

What am I doing wrong ?
Is this indeed a bug ?


What setting do you have here?

Zoom fit, whatever the test case … I checked it for all of them.

And I added an item in the OP about my system global scale = 137.5%

This is a known bug related to this. There is another report somewhere, but I do not feel like looking for it. As I recall, this might be improved when we next upgrade the Qt libraries we bundle with our binary builds (not the Qt version you supplied). You can try using the Flatpak instead, which uses Qt 5.14.

1 Like

Here is the other report, and it is from you. Basically, it is the same issue but different manifestations

Hi @shocut

thanks for looking into this.
And sorry about this !!
I admit I did not think the same root cause would cause this as well … as the font-look is quite different from the preview location / use of the screen estate.
Hence I did a dedicated test case & a separate bug report.

Should I close this bug report as well ?

Should the different symptoms (preview screen estate + font look) be logged somewhere so that a test is done (can be by a user like me) when the issue dealt with ?

Tried with the flatpak version (incl Qt 5.14.2) : no luck for the preview pane

But let’s see life from the happy side :
the font issue (other report) seems almost solved : it looks good in almost all places.
On issue left : only the preview pane timeline font is still looking bad.

I’ve added this in the other bug report.

Thanks & have a good WE !

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.