Possible Bug in the Timeline editing


#1

When I add footage to the Timeline and use the SPLIT AT PLAYHEAD (S) option and then remove one of the two clips from the Timeline, I can not apply any filters to the remaining footage on the Timeline, because the removed clip stays active no matter what.
Only way to get Shotcut working again is by re-starting it.
Short Video that explains the problem

I am not sure but I don’t think that this is working as intended.


How to cut parts of the video
#2

By clicking on the Video track box (activating it) seems to do the trick … question remains why Shotcut (thinks) that I want to apply any filters to the removed part?


#3

No problem here. But you haven’t said which version of Shotcut or which OS you are using.


#4

Well, it is a problem … sort of …
It simply doesn’t make any sense, because I removed that part for a reason and it should not interfere with the project on the timeline once it got removed.

Windows 10 64bit
Shotcut version 17.11.04


#5

Sorry, by ‘no problem here’ I mean it doesn’t work like that for me using the same version and same OS.


#6

Oooh !?

That’s strange, what colour is your Video track box, this yellow green like in my example video or blue > activated ?

The thing I don’t understand yet, is the purpose of the yellow’ish green status of the video track in the timeline.
As long as you do not cut and remove content from it everything works fine, but as soon as you do you end up with a big questionmark and you need to learn that you have to activede that video box again in order to continue your work on the remaining footage.
It’s not that big of a deal, but it should be clear that when I put something on the timeline that I want to work with this material.


#7

It’s simple really;
When the track header is Blue, filters applied are applied to the entire track.
When Olive, filters are applied to selected clip only.


#8

Thank you for clearing that up for me.

I might be right with my opservation that after I split that footage and remove a part of it that all changes in the filters are applied to the removed part of the clip instead of the remaining footage on the timeline.

Which is clearly not what I want

The issue is after the split and remove action I can not select the remaining footage by clicking on it.
The red frame tells me that it is already selected, so those visual/audio changes should show an effect on it.
Only by telling Shotcut to apply those changes to the intire track I can continue my work.

Just to reproduce this isssue

I import a video
Create a video track on the timeline
Drag and drop the video to the video track on the timeline
search for a possition to split the footage and right click > remove the unwanted part.

I just did a test …
If I delete that unwanted part of the clip by using the keyboard (delete key) it works as it should be.
So there seem to be an intentional difference between these two.
But to be honest, I don’t really see a use for the effect that the right click and remove offers me.


#9

Following your steps I run into no problems applying a filter to the remaining [and selected] clip on the timeline

REMOVE = Removes the selected portion of the clip and the space it occupies.
‘Remove’ is also used to remove empty space on the timeline.
Never is a filter applied to a removed clip, but it can be mistakenly applied to an empty space on the time line if you haven’t yet selected a section to apply the filter to (outlined in red when selected). It appears this is what you have done and is an erroneous usage. It could be said that it should be not allowed by the software, but seriously it’s intuitive to first select a clip to which you intend to apply a filter.
IOW: Simply a matter of learning how to use the software correctly.


#10

That’s true … problem is to remove a part of a clip I first have to select it … after I removed it I can not select the remaining part on the timeline because it’s already outlined red and clicking on it does nothing and those filter changes are applied to the part that got removed… at least it looks like it.
It seems that Shotcut handles this in a rather weird and confusing way for a the simple minded person like me :slight_smile:


#11

You’re right, that is nonsense and isn’t really happening.
Take care with and optimize your workflow. Make your cuts then add your filters (whatever they might be). Filters should be the last steps before exporting to the rendered video.


#12

I can confirm this is a bug and reproduced it. However, it is mainly an annoyance where changing selection is a simple workaround. I have to turn my attention away from minor bugs like this for a while to work on some much requested, long overdue features. I will flag this for followup some time in the future.


#13

Thanks @Dan Dennedy for clearing this … so, it’s a bug and not a feature :slight_smile: