Poor GPU rendering (NVENC)

(Notice: Drivers and Windows 10 are up to date)

Qmelt is literally melting my processor (i5 4460 3.4Ghz) while my 1050Ti is walking around carefree… Look at the image using the default HEVC profile:

Current job log: job-nvenc-current-state.txt (12.4 KB)

I realized that its impossible to use custom settings at this time because NVENC doesn’t work (log reports NVENC has been disabled and proceeds using CPU only)

What to do? Sit down and cry? I wasn’t using Shotcut for a while, but I remember rendering using NVENC never tickled my 1050Ti (never reached 20% processing). However, the current situation is much worse. Jobs are taking about three times longer to complete.

What happened?

I am also accepting tips and tricks to optimize my options and try to reduce rendering time without compromising quality.

Do you have the latest nvidia drivers and can you check your gpu using gpu-z as well? windows may not show utilization of the NVENC block properly inside task manager. You’re still going to see measurable cpu usage as well since the cpu has to do work keeping the gpu “fed” for video encode.

The log suggests some timestamp issues in your source file. You might consider replacing it with an intermediate I-frame format

What about the project itself ? What does it consist of roughly? e.g. If you’re using some CPU heavy filters, or poorly multithreaded filters , it might be a bottleneck for the “GPU” encoder

This is not a bug. Shotcut does not only use the GPU. Read the FAQ to understand more.

No, the log does NOT report that. It using NVENC. The job would fail otherwise.

This happened to me awhile back, with my RTX 2080. IIRC I think there was something corrupted in my Windows 10. Luckily I have a clonezilla backup of my Windows 10, I installed that and installed Shotcut and all was good. I too use HEVC all the time. Hope that helps

1 Like

Here’s my old i7 4790(non K) with a 1080, all air cooled.

1 Like

Found the reason: I played with B Frame option and later discovered my GTX 1050 Ti is not capable to handle it. https://developer.nvidia.com/video-encode-decode-gpu-support-matrix

There’s the log:

[hevc_nvenc @ 000000000e74df00] Loaded Nvenc version 9.1
[hevc_nvenc @ 000000000e74df00] Nvenc initialized successfully
[flac @ 00000000112f4640] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]
[hevc_nvenc @ 000000000e74df00] 1 CUDA capable devices found
[hevc_nvenc @ 000000000e74df00] [ GPU #0 - < GeForce GTX 1050 Ti > has Compute SM 6.1 ]
[hevc_nvenc @ 000000000e74df00] Max B-frames 3 exceed 0
[hevc_nvenc @ 000000000e74df00] No NVENC capable devices found
[hevc_nvenc @ 000000000e74df00] Nvenc unloaded

Anyway, it seems to go on NVENC.

#topic
I’ve formatted my PC couple days ago due to freezes. This is the current atempt to render using HEVC for similar project:

Much better IMHO

Hi,

to me this thread seems to be interested because I have an issue with GPU rendering, too. But in my case, I have as a result from export only a black screen with sound.
I’ve watched videos, tried ´settings, but still the same: black screen with sound.
Though it seems that the export runs normal, seen from the time it needs.
I have a GTX 1060 6GB…
Any suggestions?

Best regards
Earlybite

We have code to automatically change B frames to 0 when you select HEVC with NVENC and AMD AMF hardware encoders. However, we also let one change it because I do not have all their hardware, and new hardware and drivers could add support without me knowing.

1 Like

Hello,

I don’t really understand your issue? Can you please make a video of what you are trying to do please.

Hi,

your wish, my order. :slight_smile:

The issue is, that I want also to use GPU rendering with my GTX 1060, but…

(It’s not a good quality, but it show, what it needs.)

Best regards
Earlybite