Poor GPU rendering (NVENC)

(Notice: Drivers and Windows 10 are up to date)

Qmelt is literally melting my processor (i5 4460 3.4Ghz) while my 1050Ti is walking around carefree… Look at the image using the default HEVC profile:

Current job log: job-nvenc-current-state.txt (12.4 KB)

I realized that its impossible to use custom settings at this time because NVENC doesn’t work (log reports NVENC has been disabled and proceeds using CPU only)

What to do? Sit down and cry? I wasn’t using Shotcut for a while, but I remember rendering using NVENC never tickled my 1050Ti (never reached 20% processing). However, the current situation is much worse. Jobs are taking about three times longer to complete.

What happened?

I am also accepting tips and tricks to optimize my options and try to reduce rendering time without compromising quality.

Do you have the latest nvidia drivers and can you check your gpu using gpu-z as well? windows may not show utilization of the NVENC block properly inside task manager. You’re still going to see measurable cpu usage as well since the cpu has to do work keeping the gpu “fed” for video encode.

The log suggests some timestamp issues in your source file. You might consider replacing it with an intermediate I-frame format

What about the project itself ? What does it consist of roughly? e.g. If you’re using some CPU heavy filters, or poorly multithreaded filters , it might be a bottleneck for the “GPU” encoder

This is not a bug. Shotcut does not only use the GPU. Read the FAQ to understand more.

No, the log does NOT report that. It using NVENC. The job would fail otherwise.

This happened to me awhile back, with my RTX 2080. IIRC I think there was something corrupted in my Windows 10. Luckily I have a clonezilla backup of my Windows 10, I installed that and installed Shotcut and all was good. I too use HEVC all the time. Hope that helps

1 Like

Here’s my old i7 4790(non K) with a 1080, all air cooled.

1 Like

Found the reason: I played with B Frame option and later discovered my GTX 1050 Ti is not capable to handle it. https://developer.nvidia.com/video-encode-decode-gpu-support-matrix

There’s the log:

[hevc_nvenc @ 000000000e74df00] Loaded Nvenc version 9.1
[hevc_nvenc @ 000000000e74df00] Nvenc initialized successfully
[flac @ 00000000112f4640] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]
[hevc_nvenc @ 000000000e74df00] 1 CUDA capable devices found
[hevc_nvenc @ 000000000e74df00] [ GPU #0 - < GeForce GTX 1050 Ti > has Compute SM 6.1 ]
[hevc_nvenc @ 000000000e74df00] Max B-frames 3 exceed 0
[hevc_nvenc @ 000000000e74df00] No NVENC capable devices found
[hevc_nvenc @ 000000000e74df00] Nvenc unloaded

Anyway, it seems to go on NVENC.

I’ve formatted my PC couple days ago due to freezes. This is the current atempt to render using HEVC for similar project:

Much better IMHO


to me this thread seems to be interested because I have an issue with GPU rendering, too. But in my case, I have as a result from export only a black screen with sound.
I’ve watched videos, tried ´settings, but still the same: black screen with sound.
Though it seems that the export runs normal, seen from the time it needs.
I have a GTX 1060 6GB…
Any suggestions?

Best regards

We have code to automatically change B frames to 0 when you select HEVC with NVENC and AMD AMF hardware encoders. However, we also let one change it because I do not have all their hardware, and new hardware and drivers could add support without me knowing.

1 Like


I don’t really understand your issue? Can you please make a video of what you are trying to do please.


your wish, my order. :slight_smile:

The issue is, that I want also to use GPU rendering with my GTX 1060, but…

(It’s not a good quality, but it show, what it needs.)

Best regards


Thank you for the video. I see now what you mean. Can you please try VLC media player to see if you still get the black screen?

I do not use it…, I tried with SMPlayer and with a browser.
And I had, AFAIK, the same settings as you (like in your video), but :man_shrugging:

which shotcut version are you using?

This is still valid for the previous version…, haven’t tried yet with 19.10.20.

The only thing I can think of is may be something is corrupted with your windows OS. As this happened to me once and all I did is reload a clonezilla backup. If you have a clonezilla backup of your windows OS, try loading that to see if it’s any better. If you’re going to do a clean install of your windows OS, I highly recommend to try and learn how to use clonezilla.

Currently, no, no chance…
I’m still using Win-7 and Linux Mint 18.1, and next year I want to upgrade my computer, new CPU (maybe AMD, currently Intel i3-6100), new Motherboard, maybe new RAM (faster), and of course a M2 SSD, and then “of course” Win-10.
But I remember it!


strange, strange, strange. Where to begin…
Normally, if you have exported, you will have a picture in the new icon, and that I didn’t had. And the issue is, when I play a sound file in the SMPlayer, the whole position settings are gone. So, my idea was to test the exported file in a browser…

No it comes…
The browser, in that case, is Firefox, and it shows a black screen while playback. So I thought the export was incorrect (or so). (And, yes, that happend to me a while ago…)
But just, I hadn’t a thought about it, I double clicked on a mp4 icon with no picture and, wonder, SMPlayer shows a normal video file.
At that point raises the question: Why do I have sometimes not a picture in a new, exported, video file?
And at that point, I will try again with your settings with GPU rendering… :slight_smile:

Best regards


I just gave it again a try with GPU rendering…, but no, no video (to see), only sound. Played back with VLC. And the time to export the video, was ~ similar, as with not GPU.
But NVENC should work, because I used it earlier, as I record my flights from my flight simulator, where I used that NVIDIA recording…

Any ideas?