PLEASE HELP! Unwanted Fade Out!

For the past two videos I have edited it seemed to be okay when in the shotcut window. A normal fade to black with a 3 second duration just how I set it up to be… But when it renders it makes the fade to black like 30-40 seconds which just cuts my video short and I haven’t changed a single option in the export file menu. The only thing I have changed is updating to the newest version of shotcut and that is when this started happening. Is this a bug or am I doing something wrong?

Ex of this problem (Skip to 9:30 and see for yourself):

If possible can you take a screen shot of your timeline at the end from 9:38 to 10:17? Show the longest track (video or audio) in the screen shot.

There is a known bug that fade outs are not adjusted correctly if you adjust the duration of the clip in the timeline after you have already added the filter. This is fixed for the next version due June 2, but the workaround for now is to remove the fade out filters and re-add/-apply them. This might not be the same bug, however, as your description is a little different. v18.05 is rather buggy in general due to the introduction of major new features.

1 Like

I have tried 3 tests based on how you say one of these types of bug will occur. The first one I applied the fade out filter and did not adjust the clip and proceeded to export it. It came out perfectly fine, 3 second fade out as usual. The second test I extended the clip with the fade out filter already applied by a few seconds and then exported. But oddly it came out fine as well. The third time I tried I extended the clip even more and exported again. It came out with a 3 second audio fade but no video fade even though both audio and video fade out filters were applied…

EDIT: I got the bug to occur how it has previously. I extended the same clip with the filter applied just like the last 3 times but of course making a major extension compared to the last 3 and it happened.

Here is the view in Shotcut for the same video file at 1:21

New to the forums here so sorry if this is been said before:

I also have been having the same problem, the workaround I use is to split the clip just before I want the fade out filter to start.
I have used this way 3 times now with no issue.