Perplexed re "trasparent" and colors, and Q re subtitles

Day One with Shotcut. I LOVE the instant audio sync!

Newbie issues:

  1. Color Boards. I have a “color” on my first track (at the top, but apparently in Shotcut that is the back most track.)

I have a video cropped on the next track. But the color I put on the back most track is not showing through. I only see black. I only see the color when I click on the track itself.

I turned on background color on the cropped video, which shows the correct color, but still leaves lots of black from the backing track.

I assumed I would see through to the backing track and see the color. (see screen shot if I can get it in here correctly.)

  1. I will be using subtitles with comments throughout my video. But I will not know what font color I want to use until I get this background color stuff figured out. Can I universally “apply to all” subtitles if I want to change the color or font or text or size? Or do I need to decided that before adding more subtitles?

FYI I am coming from years of PowerDirector but modern versions do not sync audio better than 1/10" a second, which does not work for syncing audio to video of musical instruments, etc.

What method did you use to crop the video? The Crop:Rectangle has a padding colour option and you need to click on transparent. If you use the Size, Position and Rotation it should automatically make the outside transparent.

image

Yes, in Shotcut the higher (up) tracks are sitting on top of the “lower” tracks so your color backround should be at the bottom.

For the subtitle/comment colors it is individual for each “instance” of the text filter. So, unless I am not understanding the use case, there’s no “apply to all”.

Thank you. I did select transparent, but the video is surrounded by black, it does not show the green color that should be behind this cropped video clip. I have since put tracks above and below my video now with the green color installed, but they have no affect. The cropped video is surrounded by black. When I select a padded color for the crop the color shows up on two sides of the video, and the other two sides are black, as seen in my screen cap above.

PS The green color on the empty tracks only shows on the time line as green when the track is selected. I do not know if that matters, but I need to have a green background on my video with the cropped clip over top of it and it ain’t happening.

The screenshot does not show that. This color image that you see is Shotcut’s color to indicate the current track. Certain operations depend on which track is current. You make a color clip using Open Other > Color.

From your screenshot, it looks like you might have more than one filter on the video clip. It is more helpful to show the Filters for the mp4 video in your screenshot. For example, I can create something like what you show by adding a Size, Position & Rotate filter.

Do not make it more complicated than it needs to be. For example, using multiple tracks, a color clip, and Crop: Rectangle > Padding color > Transparent. Why do that when these filters have padding color and background color options included:

Maybe since it is at the bottom of this filter UI you need to scroll the Filters panel to see it.

Thanks. I have the two filers you show, crop and Position & Resize. I only turned on the padding color to demonstrate how the transparency ISN’T transparent. It is black and does not allow the green color from the backing track to show through.

Yes, it is

Your screenshot does not show a green backing track. It shows an empty V2. Here is a green backing track

Ohhh. I was saying add color and selecting the color, but I did not know I had to drag and drop it into the track. I happened to be picking a green color, so I thought that green next to your blue bar was supposed mean that color had been added to the track.

Thanks! I figured out how to do it.