Pause Causes Forward Jump On Clip

I’m a total noob with Shotcut and am having a problem using the pause control to stop a clip to set an edit point.

I have a clip that I want to edit on the timeline. I play the clip until I reach the desired edit point and then press pause. When I press the spacebar or click on the pause icon the image in the viewer jumps to a point on the clip that is after the desired edit point. If I then press the left arrow key the time code display will decrement, but the image is frozen. It stays frozen until the key is pressed numerous times (precise number varies) causing the image to snap back to a point on the clip that is just before the desired edit point. Then pressing the right arrow key will allow frame by frame advance to eventually reach the desired edit point.

Based on the sophistication of this program, and after viewing several tutorials, I’m fairly confident that this behavior is not normal.

My program download is recent, version: 23.09.29 and from

I’m running Windows 10 Home, version: 22H2, Build 19045.3570

My machine has a Intel(R) Core™ i5-9400 CPU @ 2.90GHz processor with 12Gig of RAM. The program is loaded on the C: drive which is a 500Gig SSD with 300Gig free. Video output is via the Intel UHD Graphics 630.

Any suggestions on how to remedy this problem would be greatly appreciated.

1 Like

Shotcut is having trouble seeking in your file. Maybe it is variable frame rate. Or maybe it uses a file format that is difficult to seek (like transport stream).

In the clip properties panel, you can click the “Convert…” button to convert the clip to an edit friendly format. With that, you should see frame accurate seeking.

If you want, you can share a screenshot of the clip properties for your file and we can see the encoding parameters. There might be more clues there.

Hi Brian,

Thanks for your prompt response.

The file is a “standard” .mp4 that plays on everything I’ve tried it on. It is also editable using the default Video Editor that comes with Win10.

I tried your suggestion and converted the file to a .mkv and the clip then acted as expected. It was, however, about four times the size of the original .mp4.

Not sure how to go about getting the properties you mentioned. As a guess, I right clicked the file name and got these properties:

Converting my files before I can use them is kind of a PITA, but at least it does work.
Thanks for your help.

In Shotcut, select the clip and then open the Properties panel.

OK, here it is:

Hope this helps.

The only hint about variable frame rate is the rate is 29.975728 when it should be 29.970029. That isn’t enough to trigger our VFR detection to prompt the conversion. Some people have good luck with VFR and others do not.

OK, thanks for running it down.

This topic was automatically closed after 90 days. New replies are no longer allowed.