Overlay video track with moving line

I am new to shotcut and am trying to do the following: I have a short audio track and a still image of a spectrogram. I am trying to add a simple animated overlay of a moving red vertical line (a “playhead” over the spectrogram). I created an image of the red line, added a second video track for the red line. I am attempting to use the Size and Position filter for the red line, setting one keyframe at the beginning and one at the end (using the default linear interpolation).

It works as expected BUT the red line turned grey as soon as I added the filter. I tried various things (saving with and without alpha channel) and adding the filter on my second track turns my line gray.

Any idea why this is happening, what I can do to prevent it, or if there is some better way to achieve the effect I want?
Suggestions would be much appreciated!

P.S. In the exported video (default settings, MP4) the moving line works great but it is white. So the method I’m using does not preserve the color of my original image.


Everything seems to work fine for me.
Shotcut 19.02.28, Windows 10 Home 64-bit

I have mine in the timeline though.

I’m not sure how to accomplish within the playlist.

I think the line turns grey because you have the filter selected. It’s showing the filters rectangle. if you select the track header or the clip on the lower track the grey disappears.

A simpler method is to use a color clip rather than a png. You can use the size and position filter to set it’s width and animate it.


Here’s the mlt to show you how it’s done.

Moving line.mlt (7.3 KB)

1 Like

That is helpful, thank you. I removed the second track and recreated it. But now how do I add keyframes in the timeline? When I right click on the image in the timeline I can select Properties, but not Filters (or add keyframe). And when I select properties, I can then click on Filters … but when I try to add a Size/Position filter, same behavior: it turns gray. Is there something I’m missing in the timeline itself?

Ahh - thanks! That sounds promising. I will try it.

This topic was automatically closed after 90 days. New replies are no longer allowed.