Overlay Tracks - Background Always Rendered Black

Hi there, this keeps happening whenever i have 1 video layer/track on top of another. Looks fine within Shotcut while editing, but AFTER RENDERING the entire base video is black.

Same thing happens when i tried adding text through a separate layer/track (which took me by surprise & cost me many HOURS of frustration & lost work). Thankfully it rendered fine if text was inserted as a filter directly into the base video clip (but as far as i know i can’t overlay another video onto base video like this).

Is this a bug or am i doing something wrong?
Windows 7 SP1 x64,
Shotcut version 21.03.21.
Intel i5 2500k, 16GB DDR3, Nvidia GTX1060.

(This is always the output, regardless of export encode settings.)

Background color options, alpha channel, all 0, HTML: #000000.

Which version of Shotcut at you using?
Where it says background color, click shotcut_2021-05-10_13-18-08 . This resets to transparent.

I tested with version 21.03.21 and everything works fine with 2 video clips. V2 with Size, Position, Rotate set off in the upper right corner.


Thanks for reply. As mentioned, background colors are all already resetted to “0”. Using same version of Shotcut. Inside my Shotcut view it also looks fine like yours, it is only AFTER RENDERING that the whole base/background video outputs as black.

Same problem with text & anything else added using a 2nd video track/layer, but text added into base video track as a filter outputs fine.

I’m showing the rendered video in the screenshot, but here is the actual video.

(Thanks for the example upload.)
Yeah, totally not getting it like this, & i’ve tried searching online & troubleshooting for days before finally deciding to post for help.

It’s still unknown which version you are using.
There are known bugs with 21.05.01, which is why I’m only testing with 21.03.21.
Shotcut is still in current development, every version is different.

Here is a project file for version 21.03.21 to test with your computer.
I didn’t touch the background color settings with the SPR filters on V2.
Two layer timers 210321.mlt (6.4 KB)
It will create this video once rendered. Default export settings used.


1 Like

Sorry if i wasn’t clear, was using the same version (21.03.21).

Thanks for the test file. Tested with multiple stock export settings, same result… :frowning:

After the export finishes, right click on the job and save the log file. Upload the log file here. Maybe there is a clue in it.

1 Like

Shotcut Test Log.txt (4.0 KB)
(From the same encode test above)
Ugh… Looks like a whole bunch of errors in there, don’t understand it.
Already tried uninstalling & reinstalling 21.03.21, tried running as administrator too, same result.

Edit: Tried running version 21.05.01, & this one just flat-out refuses to encode.
Shotcut 210501 Test Log.txt (2.0 KB)

Both logs suggest that something is wrong with your installation:

[producer_xml] failed to load transition "frei0r.cairoblend"
[producer_xml] failed to load transition "frei0r.cairoblend"

And this message suggests that you do not have permission to write to the desktop:

[consumer avformat] Could not open 'C:/Users/Iron Steel/Desktop/Two layer timers 210321.mp4'

As an experiment, you can try the portable version:

  1. Download this file: https://github.com/mltframework/shotcut/releases/download/v21.05.01/shotcut-win64-210501.zip
  2. Extract the zip file
  3. Double-click on shotcut.exe
  4. Open the text project and export

We also sometime see strange things like these if there is an anti-virus program blocking it. Check if you have anti-virus installed and temporarily disable it for a test. As another test, you can make an exception for shotcut in Windows Defender:

1 Like

Thanks for the developer responses. :slightly_smiling_face:

But tried all the above, running as Administrator (should have all proper permissions), & still no dice. I’m thinking it’s probably something to do with this old Windows 7, but unfortunately it’s just too much of a hassle to upgrade now, i need this video project done soon, & Shotcut is one of the few free featured video editors with native HEVC support. Sigh… :cry:

Edit: Tried Davinci Resolve & Hitfilm Express, but the Shotcut workflow & export quality settings were still the best for my needs, those had lousy native export quality settings (& output colors also differed from source). Trying Openshot & VSDC next. :cry:

Edit 2: Shotcut was still the best in my eyes. Sucks that i can’t get it to work…

From the logs you uploaded:

Can you look to verify you have this file?

Also try exporting to somewhere other than Desktop. Export to a folder like Video or Documents, or to another drive.

Also try with Use hardware encoder off or unchecked.

1 Like

Unbelievable! After dealing with this for weeks, the problem just straight up vanished! I’m not even sure which post to mark as “Solution”, as both Brian & Hudson contributed, thankyou guys for all the support! :hugs:

Steps attempted:

  1. Uninstalled 21.03.21, ran 21.05.01 Portable from another Drive Partition, exported to same partition, success finally!! :smile:
  2. But then reinstalled 21.03.21 again to test, & NOW it exports non-black to Desktop just FINE! :rofl:
  3. Test-reinstalled 21.05.01, & this version again completely failed exporting to Desktop, but exports fine non-black to another partition.

PERFECT COLOR REPRODUCTION vs source clips compared to every other free video editor above i tested today, native HEVC/H265 support, advanced 2-pass encode settings with command-line options… the Shotcut i grew to like is finally BACK! :laughing:


This topic was automatically closed after 90 days. New replies are no longer allowed.