Output file size - what am I doing wrong?


#1

Hi all - this is going to be a stupid question, but I can’t figure out what I am doing wrong here/

I have a dashcam in my car, as does a friend of mine in Europe (I live in Canada). Occasionally, as we are both ‘car guys’, we record drives through some interesting scenery and send them to one another for some fun and entertainment. My issue is that I usually combine the clips with Shotcut (my dashcam records in 5 minute long clips) into one large movie file and then upload it…all well and good.

HOWEVER, when I check the size of the 1080p dashcam clips straight from the camera, the total for all files may be, let’s say, 4.5GB. However, once I put them in Shotcut to combine them and export them as one file using the Youtube preset, the size shoots up to something like 10GB…same length of time, same 1080p quality, same audio quality, but why is the size doubled for the same quality content…?

Can anybody help me out with this conundrum? Thanks for any comments and suggestions! :slight_smile:


#2

Your dashcam video comes off the camera compressed.
When you edit and re-encode, you are decompressing then re compressing.
If the re compression and codec settings are similar then you will get a similar data size result, if they are not then you won’t.

If you are posting to YouTube, try the YouTube preset.


#3

As mentioned, I DO use the Youtube preset. As far as I know, the settings for the Youtube codec are similar to what is on my camera? Is there any way to get Shotcut to re-encode with a setting such as ‘use same format as original’ to have it re-encode in the same settings as the original clips?


#4

Sorry, eyes skipped.

Not specifically, but you could use MediaInfo to find a more accurate description of the source file properties and use that to set your output encoding settings.


#5

As an after thought, can you supply a sample of the source video for me and others to try?


#6

I just deleted the ones I had combined with Shotcut but I can pull another clip off my dashcam card in a bit…each clip is something like 400MB each at 5mins each. I’ll upload one to Google Drive to link to you in a few!


#7

Clip sample as requested: https://drive.google.com/open?id=1Pt9_gvd4ptQEM37IPyPiyWOpT-OXq76T


#8

Thanks, but if I load your 468Mb file into Shotcut then export directly to MP4 with h.264 codec I get a smaller file.

Capture

I set Shotcut to ‘Automatic’ before importing any files.
I choose mp4 from the Format dropdown.

I use this setting for Youtube all the time without any issues at all.
(Remember YouTube will re-encode anyway)


#9

Not sure what you mean by setting it to Automatic?

First thing I do when I open Shotcut is just select the open file menu and select all my clips?


#10

He means set your video mode to automatic.

image

I did the same export that @Steve_Ledger did and got the same results. The exported file is smaller than the original.

image


#11

Mine is set to Automatic already then. So you both chose the clip, selected the Youtube export preset, set it to MP4 with the h.264 codec?

That is pretty much what I do as far as I know, except that I am loading several clips and using the ‘Add All To Timeline’ function to combine them all into one video to export. I still wind up with an export video that is larger than the sum of the original clips in terms of file size…not sure what is up! :S


#12

This is my the Shotcut default YouTube export preset. I have not modified mine at all.

image


#13

No, I mentioned what I chose.
No stock preset was selected.

The only difference to sauron’s settings are the GOP, mine is 12


#14

Loaded your clip twice in the playlist and used the add all to timeline function. Exported with the YouTube preset and still got a file smaller than the sum of the two files. It came out to 811 MB.


#15

OK - I think I know what is causing it. One thing I never really understood is the quality setting. My video clips themselves are at 100% quality, let’s say, because nothing has been done to them. However, when I select the Youtube preset, the default setting for export is 60% quality. I would always up this a bit to 80% because I still don’t really get what it meant.

If all I am doing is adding my unchanged clips to Shotcut and then exporting them together as one file, I don’t get why not setting the quality to 100% doesn’t give me the same file size as the original clips…? If they are at ‘100%’ original quality before I do anything to them, why do they get so much larger when exporting to a new file?

Sorry for the stupid questions…I have done amateur video editing before in the past, but there are just things I don’t really understand about it. All I want to be able to do is take the 5-min clips I have, put them together into ONE file with the exact same quality the clips started out as and not have the file size increase for the final video file…I must be stupid as it can’t be that hard! Haha! In that case, why does the Youtube preset automatically lower the quality by default to 60% and me setting it back to 100% as the original clips would theoretically be cause the file size to increase massively?


#16

Yes that will cause a size increase.

This is something that someone with more knowledge about the nuances of exporting will need to respond to.

For that I suggest using Avidemux. It is an old application. But will do want you want. You can simply add all your videos and save them in copy mode. It just puts everything together and saves it with no quality loss and virtually the same filesize.

This thread might help with filesize and exort issues. Especially @brian’s post.


#17

Because your original source footage is already compressed, possibly by 40% = 60% IQ (Image quality)
While you are editing, the file is decompressed (opened/unpacked). If you then ramp up the IQ to 100% then zero compression is applied when re encoding. Hence the file is bigger.
So using 40% compression again (60% IQ) will ‘repack’ the file to a similar size.

This is the same as say an image file, you can save it without compression (100% IQ) or save it with some compression, the former being larger.


Shotcut Crashes. MY PC IS NOT THE PROBLEM
#18

Thanks Steve - that explanation makes a lot of sense. Sorry for being so dense, haha!


#19

Man, where were you when I needed this two weeks ago? Heh, thanks for pointing me to this tool!


#20

If the only task is to combine video files, and not edit them, I wonder if the dos command “copy/b” would work?

copy/b file01.mov + file02.mov + file03.mov newfile.mov

No decoding/encoding involved.