Opening ShotCut in full screen using Windows 10


How do I get shotcut to open in full screen in windows 10 (v 19043.1110)? Every time it opens just in the top left hand corner (as per the screen shot). I click in the maximise button in the top right and the shotcut window moves to the centre bottom of the screen. I click on the maximise button again, it finally I have shotcut in full screen mode.

My version of shotcut is 21.05.18

It’s not a #bug, as you are new to this forum, I can understand that you didn’t know about categorizing the topics, This topics is seeming to be a #help-how-to rather than #bug . Plz… Do not create topics with bugs tag, unless it’s really a bug. If you don’t know what bug is, read the article:-

I think it’s not something that is related to shotcut, it’s a windows problem, your windows is not correctly sizing the window because you might have closed it in the small size last time, try to leave it full sized before closing, than again open it. This might solve the problem, or you could try the latest stable version 21.03.21 if the problem still exists after even doing the above steps.

If nothing works, you might go to Microsoft Forum and create a new thread named as Program doesn’t get sized correctly while opening, then the Windows professionals might give you the answer. Because the problem doesn’t seem to be shotcut related for me, it rather seems to be windows related.

Righ click the icon on Windows and select Poperties->General then make sure that “Run” options does not say “Minimised” as below:

Use “Normal window”, or “Maximised”.

1 Like

Thank you for your reply. I have been a software developer for 35 years so I know what a bug is. I assumed that since shotcut is the only program that constantly opens in a small window that it was a bug with the software, rather than a microsoft feature. I shall revert back to the stable version you suggest and see what happens.

1 Like

Thank you for the reply - I have already set that to maximised and it had no effect on how the program opens.

I already said “if”.

Well, you can directly go to Microsoft Forum without performing any steps and see what they suggest you about this, I have no idea, It happens with me but I don’t notice that usually, it doesn’t happens with shotcut, but for me this happens with File Explorer. Have you just tried to restart you pc?

The notes page (Shotcut - Command Line Options) claims that there is a --fulscreen option

Usage: shotcut [options] [FILE]...

  -h, --help                        Displays this help.
  -v, --version                     Displays version information.
  --fullscreen                      Fill the screen with the Shotcut window.
  --noupgrade                       Hide upgrade prompt and menu item.
  --gpu                             Use GPU processing.
  --clear-recent                    Clear Recent on Exit
  --appdata <directory>             The directory for app configuration and data.
  --QT_SCALE_FACTOR <number>        The scale factor for a high-DPI screen
  --QT_SCREEN_SCALE_FACTORS <list>  A semicolon-separated list of scale factors for each screen
  --QT_SCALE_FACTOR_ROUNDING_POLICY <string> How to handle a fractional display scale:
                                    Round, Ceil, Floor, RoundPreferFloor, PassThrough

  [FILE]...                         Zero or more files or folders to open

But when I change the Windows 10 Shotcut icon’s target to include this Shotcut fails to start saying:


Perhaps @shotcut can explain why.

EDIT - This iformation is out-of-date, since the option appears to have been removed as using the --help option does not show it.

Fullscreen is not exactly the same as maximized. Fullscreen does not show window title bar and Windows task bar. But fullscreen is problematic on Windows and therefore connected instead to the window maximized state - at least the menu item. The command line option is not available.

I am unable to reproduce the problem reported. It seems to be stuck in some mismatching maximized state. I suggest to fiddle with it to get it out of maximized and exit with in normal size. Then, it should reopen as normal. Maybe saving while maximized will work again after this, but maybe not and it has some weird behavior on this system for some unknown reason. In that case, since the poster is a veteran developer and this is open source, they can try fix it: Shotcut - How To Use the Windows SDK

1 Like

Since the fullscreen menu option and the shortcut (F11) don’t do anything useful on windows, would it make sense to be remapped to External Monitor on current screen*? (basically a one key shortcut to the big video player without any distractions).

I find the external monitor feature really useful but it’s too cumbersome to use it as it’s not very quick to activate (navigate to the option in the menu + submenu). Also I need to first move shotcut to the other monitor so I can select the main monitor from the list (*which I don’t understand why it is disabled in the first place, it artificially limits one monitor users completely (you can alt+tab to bring the main window back anyway)).

No because that is inconsistent and overloading behavior. There could be a different keyboard shortcut to toggle the first or previous non-current screen. It makes no sense to use the same screen the app UI is already on because it will cover itself. External monitor is not considered to be a full screen player as it has no visible controls, not even a close or exit.

This topic was automatically closed after 89 days. New replies are no longer allowed.