Opened Clicked Update 23.06.14 CRASH Repeatedly

I opened the “app” , I’m on a PC it was fine.
“Click here for update” Okay. It will not reopen.
Uninstalled reinstalled Same Problem. Ran as Admin. Nope.
I get the icon in the center screen as usual and then it just stops.
Please help?

Hate to say that it works fine for me on my Windows 10 computer, but I know that doesn’t help you. I’m guessing you have a Windows 10/11 computer.

If you don’t have Windows 10/11, perhaps the release notes may help.

From this year’s release notes of 23.05 Shotcut - New Version 23.05

These changes will also be with 23.06.14

If you do need last year’s version of 22.12 Click here.

Windows 10
No. All I did was click “update” and poof gone. Won’t open.

On Linux, it happens when I try to stabilise camera footage.

Windows Troubleshooter says NO.
It tried to run a Windows 7 and 8 against it looking for whatever the hell it was looking for.
Other editing software sucks. Please help?

You overlooked this pinned topic

More than likely your system lacks Direct3D 11, and you need to run the older version listed under Windows 7 on the downloads page.

That version is old and was not a release version.

I had it on Windows 10. It worked just fine for years.
Just above the timeline there was a “Click here to update” bar. I clicked it.
It no longer works, it won’t open.

V 21 12 24. I had an issue back then, They archived the conversation in my account here. Thank you for doing that Dan.
I should have looked for THAT older version first.

Thank you all. Sorry if needed. All better now.

This topic was automatically closed after 90 days. New replies are no longer allowed.