Open Existing Project...and Timeline is Blank?


I’m a complete noob at Shotcut, so if this is a dumb question please forgive me! I couldn’t find a similar issue anywhere else on the forum.

I put together a video a month ago using Shotcut, but it became obvious I needed to redo the audio track. So I recorded the new one, then opened the project from last month in Shotcut (the MLT XML file).

When I open the file, the video I created is there, and plays…but there’s nothing in the Timeline. No video, no audio, nothing shows. I can’t remove the bad audio track, replace it with the good one, or re-time the video to match the audio!

I hate thinking that I’m going to have to re-do the entire project another time… any suggestions?

I’m guessing all of the original files for the project are all still in the same location from when you saved the mlt file. I’m guessing you clicked “Open MLT XML As Clip”.

Just click on “Open File” then pick the mlt file.
Open File

Here are a few examples of what a mlt file should/may look like in Windows 10.
testsdv1 is testsdv1.mlt
test57 is test57.mlt
Test 102

Test 106

Thanks for the response.

I definitely used File>Open File… when opening the MLT file. My personal settings for Windows 10 have file extensions visible, so it’s pretty easy for me to identify an MLT file.

The files should be in the locations they were in; I haven’t done much housecleaning on my hard drive recently. And I know that when there are files Shotcut can’t find, it puts up an error message:

Screenshot (4)

(from a different project)

Open up your MLT file in Notepad ++ or regular Windows Notepad and see where it shows your file paths.

Is it possible you saved the MLT before you added your files to the project then forgot to save it? This is something I still continue to do all of the time. As far as I know, Shotcut doesn’t auto-save files. Maybe someone could correct me on this if I am wrong.

mlt code resource 1

mlt code resource 2

test57.mlt (4.4 KB)
Created with Shotcut 18.05.03
Tested with both 18.05.03 and 18.05.08

What you could do, do a new project with your saved video MP4 file in V1, create new Audio Track (A1).
add audio track

Mute (V1) Video track

I’ll check on that. Good idea.

So I opened it in Notepad++, and it looks like this…

So yeah, I think the file is wonky. Thanks for the suggestion to use the MP4 and re-do the audio, I think I’ll try that. Thanks!

I’m using Notepad ++ version 7.5.6
Perhaps your version is outdated where it doesn’t detect mlt files.
MLT files are encoded with UTF-8 not ANSI. That’s why it looks all weird.

notepad plus utf 8 2
notepad plus utf 8 1

I adjusted the settings in Notepad++ to XML and UTF-8. Still very similar. And i’m using the same version of Notepad++ as you are. Oh well. :expressionless:

Does it look the same with regular Windows Notepad? It should be readible, it just won’t be separated like Notepad ++ shows. If it does show the same thing, it’s possible the file got corrupted in some manner.

This is wonderful example to remind myself to be more proficient with how I save my project files.