Opacity not working in latest version

I am another recruit to shotcut after years with WMM.
After a few weeks most problems have been solved with help and tutorials _ except I cannot get opacity to work. I have latest version 23.09.29 and W10 64bit.2023-11-09T00:00:00Z

Do you have Settings > GPU Effects turned on or off in the menu?

Thank you so much for helping. I don’t know is the answer. I have gone to settings/GPU effects which states “a project created with GPU cannot be converted to a CPU-only project later”. “Do you want to enable GPU & restart”. If I answer “yes” does that mean I lose my existing project &restart a new one?
I would add I have 2 tracks and understand how it should react.

What did you apply the filter to? Does it have other filters active, did you accidentally set the opacity to 0% (i.e. transparent)… Need more detail as to what you have done that doesn’t work

Hi @coly

The Opacity filter won’t work if the clip you apply it to is on track V1
OR
If the clip the clip you apply it to is on any other track but the track(s) bellow is/are empty.

3 Likes

Thank you for helping. I have the clip (a face) on V2 and there is a title clip directly under on V1.
Alpha 255, no other filters, opacity up to 100%.
I selected the V2 clip , added filter opacity, I used key frrame which shows a diag line across the clip, but no opacity effect at all.

thankyou for replying, please see my comments on patc3 reply.
I have no idea if to change the GPU setting.

What exactly is your title clip?

Is it a transparent clip, with a Text filter applied to it?
If so, this is almost as if you had nothing under your clip on V2. The solution in that case would be to give a color to your transparent clip on V1

1 Like

Hello again, the title clip on V1 has a black background with the fancy text logo downloaded from another site.

I have moved the face on V2 to be on the top of a normal picture clip on V1 but still no opacity effect.

So I take it that your Text logo is an image.
Is it a JPG? A PNG?
If it is a PNG, are you sure the background is opaque?

If the PNG is white text (or any other color) on a transparent background, that transparent background will look black in the Shotcut preview

So kind of you to help this old man. As I mentioned I have moved the top clip V2 over a normal photo clip (garden) on V1 - so the title isn’t the problem.

sorry to keep pestering. On same subject - opacity.
I started another video and opacity works fine, so it is something in my settings on the first video I suppose.
I have tried different pictures placed on V1 V2 but dosn’t work. Help is appreciated, thankyou.