Only play visibles Video track Audio


I have two video sources on individual tracks, each with their individual embedded audio.
I’ve cut out segments of the higher strata track, leaving those I want to show, and having the lower track come through the holes.
While this works great for the video, I’m getting combined audio, instead of only the audio from the higher track.

As far as I can tell this is inteded behavior. But is there a simpler way to mute the lower tracks audio when the higher track is active, without chopping up the lower track as well and mute each individual part?

This mutes the whole track.

When you load the source clip for the first time in the source viewer, or before you cut the clip on the timeline you can turn off the audio on the clip itself in Properties.

Thanks, but I don’t want to mute the whole track.

I want only the v1 audio, when there is nothing in v2 (which of course works just fine).
I now also want only the v2 audio, without the v1 audio, when there is an active part in v2.

I could achieve this by cutting v1 in the same places as v2 and muting/removing the segments in question.
I just don’t want to do this fiddly work, if I don’t have to.

Another option if you’re going to be applying filters, just copy the mute filter, from one clip, and keep pasting it as you move along.

Welcome to video editing, lol.

Once you figure out your work flow, things will get a lot easier.

If there’s no easy way to have audio behave like video (overlay instead of merge) I doubt that it’ll get easier for my usage scenarios.
The Shotcut GUI and preview already got noticeably slower with my 50-odd cuts. Not looking forward to cutting up the basetrack as well. But oh well…

Thanks for your help none the less :slight_smile:

You do not need to. You can instead use Keyframes on a gain filter.

While still more fiddly than a per track audio behavior selector akin to “Blend mode”, this at least doesn’t lead to extra clutter.

Thanks :slight_smile:

This topic was automatically closed after 90 days. New replies are no longer allowed.