NVIDIA codecs for export


#1

I have read some posts in witch users asked if Shotcut uses Nvidia codecs for rendering exports. YES it uses these encoders and it is very fast!!! I finally found what I waas looking for since I started to make videos. In my experience, LinuxMint, I need at first install eveerything about cuda and cuda headers. I replaced the old ffmpeg (Linux default) and I RECOMPILED ffmpeg from the last uploaded code ENABLING cuda encorders by ./configure!! After that I copied the ffmpeg compiled in both paths: /usr/bin and /usr/local/bin. The installable version of Shotcut doesn’t list the cuda encoders. After the rebuilding of ffmpeg by hands (compiling) I copied the portable version on my home folder. And thet varsion LISTS all encoders!! It is impressively fast! I removed Handbrake and all video utilities!!! I make conversions with Shotcut too. Nothing can helps more than this! If you want help write me here. Not for Windows, I don’t consider Windows.


#2

Shotcut for Linux already comes with FFmpeg compiled for NVENC since about a year now. What are you talking about?


#3

Hi, sorry if something is wrongly described. When I installed Linux (not only this time) in the past I had to rebuild ffmpeg because it didn’t use the CUDA engine (Winff). FFmpeg comes with LinuxMint in default installations. To get ffmpeg properly work with cuda engine we must install CUDA completely and OpenCL completely. After that (I experimented in the past) I can install software based on ffmpeg. When I installed Shotcut (via Flatpack) I noticed that CUDA encoders was not in the list during exports. I mean that in the export step, choosing the encoding, the list was long but without CUDA encoders. After the rebuilding ffmpeg (uninstall and recompile it in /usr/bin/) with CUDA enabled, in config, Shotcut lists the cuda encoders in its list. I send you two images. I remade all the job, friend, I want to do all in a perfect way. I send you two images. The first is Shotcut based on old ffmpeg in my system, and the second after I rebuilded it. I don’t know if ffmpeg is the cause of the issue but the versions are different. See the pics please. Thanks and regards for your work!


#4

Is it possible that this is a linux mint issue specifically?


#5

This is a Flatpak build issue. I am not yet personally maintaining it, but @pete has been and might take a look into it.


#6

I added nvenc support to the flatpak and tested it with my GTX 960. Please update!


#7

Yes I confirm that for me worked. I will use flatpak for the future. Thanks.